Forum: Rails deployment How to get Subversion working with Apache

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Af5852540c2dd3486d1484f4beefdef9?d=identicon&s=25 Mike Glaz (Guest)
on 2007-06-05 21:22
I know how to create a Virtual Server with Apache
I know how to create a file:// repository and import and update code.

But my next step is to get Subversion working with Apache so that I can
access my repository through http:// in order to get Capistrano to do
its next step.

9cace61bc2a5972d44d5e1a1b8c145af?d=identicon&s=25 Bram Whillock (bramski)
on 2007-06-06 17:54
(Received via mailing list)
You may get a better response out of the svn usenet group, just fyi. (step 1 may be
different for you).

On Jun 5, 12:22 pm, Mike Glaz <>
Af5852540c2dd3486d1484f4beefdef9?d=identicon&s=25 Mike Glaz (mikeglaz)
on 2007-06-07 20:52
OK, when I had Apache 2.0.59 installed this is how I got my SVN server
setup and going:

<VirtualHost *:80>
<Location />
  DAV svn
  SVNPath /home/mike/repos
DocumentRoot /home/mike/www/svn/htdocs

and of course I had these two lines:
LoadModule dav_svn_module     modules/
LoadModule authz_svn_module  modules/

Now, I upgraded to Apache 2.2.4 and I get a blank page when I point my
browser to my SVN server at  The other odd thing is that
all my other Virtual Server pages are blank as well.  But when I remove
the second line above:
#LoadModule authz_svn_module  modules/
then all my Virtual Server pages reappear.  Except of course for
Af5852540c2dd3486d1484f4beefdef9?d=identicon&s=25 Mike Glaz (mikeglaz)
on 2007-06-07 22:15
I looked inside my Apache error log and this is what I get every time I
try to access

[Thu Jun 07 15:12:41 2007] [warn] Init: Session Cache is not configured
[hint: SSLSessionCache]
[Thu Jun 07 15:12:41 2007] [notice] Apache/2.2.4 (Unix) mod_ssl/2.2.4
OpenSSL/0.9.8c DAV/2 SVN/1.4.3 configured -- resuming normal operations
[Thu Jun 07 15:12:49 2007] [notice] child pid 23678 exit signal
Segmentation fault (11)
This topic is locked and can not be replied to.