I have this problem win Rubygem I don't now what to do rubygems-0.9.4 =============================================================================== /usr/lib/ruby/site_ruby/1.8/rubygems.rb:84:Warning: require_gem is obsolete. Use gem instead. /usr/lib/ruby/site_ruby/1.8/rubygems.rb:76:in `active_gem_with_options': undefined method `activate' for Gem:Module (NoMethodError) from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:61:in `require' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:84 from /var/lib/asterisk/agi-bin/comprobar-festivos.rb:17:in `require' from /var/lib/asterisk/agi-bin/comprobar-festivos.rb:17 -- AGI Script comprobar-festivos.rb completed, returning 0 =================================================================================
on 2007-06-03 20:53
on 2007-06-04 03:16
On Jun 3, 2:53 pm, "Daniel Sánchez" <daniels...@gmail.com> wrote: > from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:61:in `require' > from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:84 > from /var/lib/asterisk/agi-bin/comprobar-festivos.rb:17:in > `require' > from /var/lib/asterisk/agi-bin/comprobar-festivos.rb:17 > -- AGI Script comprobar-festivos.rb completed, returning 0 > ================================================================================= > > -- > Posted viahttp://www.ruby-forum.com/. Did you use? 'require_gem <genname>' In that case, use 'require <gemname>' This is what the error message is telling you. I have had problems with rubygems 0.9.4 and 0.9.3 on Windows. My solution was to re-install Ruby which has rubygems 0.9.2, which works fine. My understanding is that it is install a prior version of rubygems without having to re-install ruby. Hopes, this helps.
on 2007-06-04 14:35
On 6/3/07, bbiker <email@example.com> wrote: > On Jun 3, 2:53 pm, "Daniel Sánchez" <daniels...@gmail.com> wrote: > > I have this problem win Rubygem > > > > I don't now what to do > > rubygems-0.9.4 > Did you use? > 'require_gem <genname>' > > In that case, use 'require <gemname>' This is incorrect. It is not necessarily the case that the gem name matches the require identity. As an example, Text::Format is provided as a gem text-format and is activated with "require 'text/format'". As to the OP's problems, I don't know anything about it right now. -austin