Forum: Ruby on Rails [ActiveRecord with Rails] sqlite3-ruby installed, but can't

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
8987d77750701f93bb78228c86d2c205?d=identicon&s=25 Stéphane Wirtel (Guest)
on 2007-06-03 11:24
(Received via mailing list)
Hi all,

platform: win32

I try to use rails with a sqlite3 backend, but I have got an error
with rake db:migrate.
It seems that can not find the Init_sqlite3.

the sqlite3-ruby(win32) gem is installed in the gem repository.

If I use AR without Rails, I do not have problems, but if I want to
use rails, "rake db:migrate" can not load Init_sqlite3.

the sqlite3.dll is in vendor directory, and in the past I have never
seen this bug :(

Rails => 1.2.3
Ruby : 1.8.6
sqlite3-ruby : 1.2.1 (win32)


This topic is locked and can not be replied to.