Forum: Ruby on Rails MiniMagick... Core Dump when Reszing Images?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Miles (Guest)
on 2007-05-29 01:27
(Received via mailing list)
Hi,

I'm using Mini Magick and that attachment_fu plugin to resize images
that the user uploads. Everything looks okay in my code, but I get a
core dump every time an image is uploaded.

The file successfully posts to the application, I can see that the
original file gets copied into the folder correctly. It appears that
it dumps immediately after that. I'm using Mongrel behind Apache 2 and
there aren't any interesting error messages in the log files.

Has anyone seen anything like this before? I've been banging away at
it for a while.

Thank you,
-- Miles

PS: I am currently using...

  FreeBSD 6.1
  Apache 2.2.4
  MySQL 5.0.41
  ImageMagick 6.2.9

  Ruby 1.8.6
  Rails 1.2.3
  Mongrel 1.0.1
  Mongrel_Cluster 0.2.1
  Mini_Magick 1.2.0
Miles (Guest)
on 2007-05-29 01:43
(Received via mailing list)
I ran the rake on the mini_magick gem and it looks really unhapppy...
I'm starting to think this might be an ImageMagick installation
problem.

(in /usr/local/lib/ruby/gems/1.8/gems/mini_magick-1.2.0)
/usr/local/bin/ruby18 -Ilib:lib "/usr/local/lib/ruby/gems/1.8/gems/
rake-0.7.3/lib/rake/rake_test_loader.rb" "test/mini_magick_test.rb"
Loaded suite /usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake/
rake_test_loader
Started
....mogrify: unable to open module file `/usr/local/lib/ImageMagick/
modules-Q16/coders/2.la': No such file or directory.
.....mogrify: unable to open module file `/usr/local/lib/ImageMagick/
modules-Q16/coders/3.la': No such file or directory.
.mogrify: unable to open module file `/usr/local/lib/ImageMagick/
modules-Q16/coders/4.la': No such file or directory.
..identify: no decode delegate for this image format `/usr/local/lib/
ruby/gems/1.8/gems/mini_magick-1.2.0/test/not_an_image.php'.
..
Finished in 2.536952 seconds.

-- Miles
Miles (Guest)
on 2007-05-29 03:16
(Received via mailing list)
I reinstalled ImageMagick and mini_magick looks a little happier. When
I run the tests, this is what I get:

(in /usr/local/lib/ruby/gems/1.8/gems/mini_magick-1.2.0)
/usr/local/bin/ruby18 -Ilib:lib "/usr/local/lib/ruby/gems/1.8/gems/
rake-0.7.3/lib/rake/rake_test_loader.rb" "test/mini_magick_test.rb"
Loaded suite /usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake/
rake_test_loader
Started
....mogrify: unable to open module file `/usr/local/lib/ImageMagick/
modules-Q16/coders/2.la': No such file or directory.
.....mogrify: unable to open module file `/usr/local/lib/ImageMagick/
modules-Q16/coders/3.la': No such file or directory.
.mogrify: unable to open module file `/usr/local/lib/ImageMagick/
modules-Q16/coders/4.la': No such file or directory.
..identify: no decode delegate for this image format `/usr/local/lib/
ruby/gems/1.8/gems/mini_magick-1.2.0/test/not_an_image.php'.
..
Finished in 9.735413 seconds.

14 tests, 20 assertions, 0 failures, 0 errors

No failures or errors is a good thing, but I don't know about those
results. Maybe that's how it's supposed to look, but I'm suspicious.
Anyway, I'm turning my attention to attachment_fu next.

-- Miles
Miles (Guest)
on 2007-05-30 15:56
(Received via mailing list)
I gave up on attachment_fu and wrote my own code to do generate the
thumbnails (I used Mini Magick). It's working great, this definitely
must have been some kind of problem with attachment_fu.

-- Miles
This topic is locked and can not be replied to.