Forum: Rails deployment deploying to a mini

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
C0326cb6860a3b54e7896c0f7ee5143c?d=identicon&s=25 Scott Ballantyne (Guest)
on 2007-05-24 16:23
(Received via mailing list)
I have a mac mini colocated, and I'm having a heck of a time automating
deployment.  I was wondering if anyone has had success with apache2 in
front
of a pack of mongrels on a mini.  Most of the configurations that I have
found are for lighty.  However, I'm more familiar with apache and would
prefer that.  Please advise.
919c90c211c1973355e7214bce7bb5a9?d=identicon&s=25 Kordova (Guest)
on 2007-05-25 03:07
(Received via mailing list)
What specific issues are you having?
C0326cb6860a3b54e7896c0f7ee5143c?d=identicon&s=25 Scott Ballantyne (Guest)
on 2007-05-25 03:14
(Received via mailing list)
Originally, I was getting svnadmin not found, and mysql not found, but
they
were in the path.  But I think I may have figured it out.  found this
little
morsel.

>Then there's the fix to get Capistrano's remote tasks to work with the
Darwin Ports environment. These
>tasks execute the command directly via ssh (they don't log in to a full
shell, I'm not sure what the term
>is for that). It's like executing ssh tom@blah.com "pwd" and it doesn't get
the full environment you'd get when
>logging into a shell. It gets a very restricted environment that you can't
normally change. So you must
>change a setting for sshd to allow yourself to setup extra environment
variables for these ssh'ed commands.

>So open /etc/sshd_config and make sure the line:

>PermitUserEnvironment yes

>...exists and is uncommented. Now set up the custom environment for your
user (the user you deploy as) by >creating the file ~/.ssh/environment
and
adding:

>PATH=/opt/local/bin:/opt/local/sbin:/opt/local/apache2/bin:/bin:/sbin:/usr/bin

>That's it! Although I think you have to restart sshd by toggling Remote
Login off and on in Sharing preferences or >rebooting hte machine.
http://www.smallroomsoftware.com/articles/2006/2/2...


seems to take care of that problem. Now I just have to get apache
pointed at
rails and I should be good.

Scott
This topic is locked and can not be replied to.