Forum: Ruby on Rails Newbie having trouble with RubyGems

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
1f77113371c7d36eae5c8a1f10137438?d=identicon&s=25 Pete (Guest)
on 2007-05-24 03:29
(Received via mailing list)
I am in the process of installing Ruby on Rails on AIX 5L 5.2.  I was
unable to compile Ruby but successfully found a set of binaries for
AIX 5.1 which I deployed and tested.  The Ruby tutorial I walked
through using these binaries worked flawlessly.

So I tired to install Gems using the ruby setup.rb command and I get
the following error:

<--- lib/rubygems/
<--- lib/
/usr/local/ruby/lib/ruby/1.8/powerpc-aix5.1.0.0/digest/ load
failed -
        from /usr/local/ruby/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:27:in `require'


I am not familar with AIX (or any flavor of Unix for that matter) but
I need to get Ruby on Rails running in this environment if possible.

Any ideas on how to resolve the load failure on the object?  Is
it because the binaries are for AIX 5.1 and I am running AIX 5.2?
This topic is locked and can not be replied to.