Forum: Ruby cygwin: no such file to load -- ubygem

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
C667185722eaecf12461cb423dc8b410?d=identicon&s=25 Ronald Fischer (Guest)
on 2007-05-14 18:37
(Received via mailing list)
I now have - thanks to the help of many readers of this mailing list -
Ruby 1.8.5 and gem 0.9.3 for both Cygwin and Windows.

Under Cygwin, however, ruby doesn't seem to make use of the installed

~/tmp $ ruby -rubygem t2.rb
ruby: no such file to load -- ubygem (LoadError)

Under pure Windows, it works fine.

Any idea why this happens? Note that under Cygwin, I use the Ruby
which I can load via the Cygwin setup program.

97550977337c9f0a0e1a9553e55bfaa0?d=identicon&s=25 Jano Svitok (Guest)
on 2007-05-14 18:43
(Received via mailing list)
missing "s" rubygems
70b0265140eaff6e312eb3efcff3c195?d=identicon&s=25 Benjamin Atkin (benatkin)
on 2007-05-14 23:28
(Received via mailing list)
I had that problem too. I don't quite remember how I fixed it, but I
think I found this page:

He says that he experienced the problem, and he thinks it's because he
had both the one-click installer and cygwin (I have this same setup at
work -- both one-click installer and cygwin). He didn't dig too much
into it, though, he just installed rubygems manually. I think this is
what I did, too, but I'm not sure.

To install rubygems without a working rubygem setup:

- Follow the link on his blog to rubygems
- Download the latest tarball (.tar.gz)
- Unpack the tarball using cygwin or 7-zip
- Run "ruby setup.rb install" inside the directory

I think it's a pure ruby package (no C code) so you shouldn't need
anything extra to install it. Once you've installed it, you should
hopefully be able to use gems.

C475cffda1800fbc3f3af17bc10c220f?d=identicon&s=25 Curt (Work) Hibbs (Guest)
on 2007-05-15 00:26
(Received via mailing list)
The One-Click installer sets the environment variable RUBYOPT to the
value "rubygems" to automatically require the the RubyGems package
(this is a bit of a trick since the "r" is the require option, and the
file being required is named "ubygems.rb".

Anyway, if you get rid of the RUBYOPT variable it should fix your

70b0265140eaff6e312eb3efcff3c195?d=identicon&s=25 Benjamin Atkin (benatkin)
on 2007-05-15 00:50
(Received via mailing list)
I looked and I found "ubygems.rb" in /usr/lib/ruby/site_ruby/1.8/.
Interesting. That is a bit of a trick.

Most people will probably want to do what I did and install rubygems
from the tarball, though, since pretty much all ruby users use gems.
I'm not sure whether rubygems is missing or if it doesn't have the
normal configuration when cygwin is first installed with the ruby
package, but either way, it's not the ideal configuration for most
ruby users, and it can be fixed by unpacking the tarball and
installing rubygems.

C667185722eaecf12461cb423dc8b410?d=identicon&s=25 Ronald Fischer (Guest)
on 2007-05-15 11:53
(Received via mailing list)
> missing "s" rubygems

Thank you - that was it! Stupid me!!

This topic is locked and can not be replied to.