Forum: Ferret Memory leak Windows XP SP2 related to search involving 'ä'

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
264613e67adeb6c9cb37b4e3a8deda2e?d=identicon&s=25 Tina (Guest)
on 2007-05-12 00:05
Hi there -
I have read through the posts here that seem related to this problem and
tried all the suggested solutions. None of them seem to fix my problem:

I am running Windows XP SP2, MySql 5.2, ruby-1.8.5, ferret-0.11.4
Right now I am still running everything in WEBrick

I set up my system according to this:

(as far as I could since I am not running Linux and Apache2)

When doing a full_text_search that involves a word with an 'ä', the
ruby.exe process goes nuts and keeps eating up memory until the system
crashes (or I kill the process). Interestingly, this does not happen for
any other Umlaut.

I am guessing that the problem may have something to do with the locale
of Windows. I tried to play around with the 'Regional and Language
Options', but nothing seemed to help.

I would be most grateful for any help or suggestions on this!
Thanks, Tina
F1d089ddcbe283f72522a98706c55e02?d=identicon&s=25 Tamas Tompa (Guest)
on 2007-05-29 19:02

I've the same problem, same platform: windows xp, same versions...

There's a serious memory leak, while processing the unicode search!

Is there any hope, that you will fix this problem under win xp?
Can i help you? (i can send logs, any information), but it's very

Please answer,
Thank you,
This topic is locked and can not be replied to.