Forum: GNU Radio usrp not found until power cycled

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
unknown (Guest)
on 2007-05-11 21:48
(Received via mailing list)
Hi all gnuradio enthusiasts,

I just obtained a brand new USRP and it seems to work fine (so far WFM
via TVRRX tested),
however, after the python script ends, fffe:0002 disappears from lsusb
and gnuradio cannot find the USRP until I cycle the usrp power.
I am running gnuradio 3.0.2 on a up-to-date gentoo with 2.6.21 kernel.
All other USB devices seem to work fine.
Is this problem already known? Could it be a problem of USRP firmware,
or
should I search rather in the computer?

Thanks for advice,

Jiri
Johnathan Corgan (Guest)
on 2007-05-11 22:08
(Received via mailing list)
Jiri Pittner wrote:

> I just obtained a brand new USRP and it seems to work fine (so far WFM via TVRRX 
tested),
> however, after the python script ends, fffe:0002 disappears from lsusb
> and gnuradio cannot find the USRP until I cycle the usrp power.
> I am running gnuradio 3.0.2 on a up-to-date gentoo with 2.6.21 kernel.

This is a known bug in the USRP firmware affecting versions 3.0.3 and
older when using Linux kernel 2.6.20 and newer.  You can obtain a
version of GNU Radio with a fix applied by using the Subversion version
control client as documented:

http://gnuradio.org/trac/wiki/BuildGuide

The stable branch in the repository that you need to check out is:

http://gnuradio.org/svn/gnuradio/branches/releases/3.0

--
Johnathan Corgan
Corgan Enterprises LLC
http://corganenterprises.com
Michael Dickens (Guest)
on 2007-05-12 03:19
(Received via mailing list)
On May 11, 2007, at 4:07 PM, Johnathan Corgan wrote:
> older when using Linux kernel 2.6.20 and newer.  You can obtain a
> version of GNU Radio with a fix applied by using the Subversion
> version
> control client as documented:
>
> http://gnuradio.org/trac/wiki/BuildGuide
>
> The stable branch in the repository that you need to check out is:
>
> http://gnuradio.org/svn/gnuradio/branches/releases/3.0

Interestingly, I recently create a VMware VM with Ubuntu Fiesty
specifically for GNU Radio (and an otherwise identical one with
Edgy).  I'm using the latest SVN, and it seems to still have this
issue, or maybe something related to it.  I even added a comment to
the Ubuntu install guide on the GNU Radio Wiki to that effect, the
primary reason being that this does not seem necessary with the Edgy
VM, and thus it's a high probability of this being an issue between
the newer Linux kernel and the USRP's USB code.

Actually, rebooting doesn't always work either, but more often than
not it does the trick; seems to have something to do with hot-
plugging the USRP versus booting up with it already plugged in, at
least in my testing.

Again, this is with the latest SVN, which includes USB fixes ... I
can add that the official 3.0.3 release (before the fixes) just
doesn't work on Fiesty, so the fixes are getting closer to providing
full ("correct") functionality under the new kernel. - MLD
Michael Dickens (Guest)
on 2007-05-13 04:10
(Received via mailing list)
After some off-list discussion, this is most-likely a VMware VM
issue, and has nothing to do with GNU Radio itself running on Feisty
- with the fix the Johnathan wrote about previously in this thread.
I will see if the VMware folks can address the issue. - MLD
This topic is locked and can not be replied to.