Forum: Radiant CMS Search Plugin - rake migrations error?; How to use?

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
7c0fa8fb73fe4c951ea79b476007c77d?d=identicon&s=25 Victor Hooi (victorhooi)
on 2007-05-11 03:41
I'm trying to add the "search" plugin to my Radiant site, and
encountering some problems. Firstly, I checkedout a copy to my
vendor/extensions folder.

[code]svn export

I then run the rake command as stated on the wiki.
[code]rake db:migrate:extensions[/code]

However, this produced the following error:
[code]Extensions cannot be used until Radiant migrations are up to
Anyway, I restarted my web-browser, and the search plugin seemed to
appear in the extensions list. However, how exactly would I go about
using this plugin? And will there be any ill effects from the rake
db:migrate command not working?

8802b1fa1b53e2197beea9454244f847?d=identicon&s=25 Sean Cribbs (Guest)
on 2007-05-11 06:59
(Received via mailing list)
1) You need to run rake db:migrate regardless.
2) The search extension doesn't have any migrations, so no worries

Fb53349b81df95c8ed28ca8ccabf7d7b?d=identicon&s=25 Eli Kroumova (elikr)
on 2007-05-24 12:52
I have just updated a project from 0.5.2 to 0.6 and when I run rake
db:migrate I only obtain the message "Extensions cannot be used until
Radiant migrations are up to date." And when I run script/server there
was an error message that the extension_meta table does not exists, so
indeed the migrations have not been executed.

The problem comes from the fact that the schema_info.version for my
project was 36 and the version for radiant 0.5 is 9. So, the solution
was to change the schema_version to 9 and then execute rake db:migrate.
This topic is locked and can not be replied to.