Forum: Ruby AD over SSL using Net/LDAP?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
A53a0c447013812c46483662ce2547d9?d=identicon&s=25 Amos (Guest)
on 2007-05-11 01:02
(Received via mailing list)
Has anybody gotten Net/LDAP (0.4) to work with AD over SSL? I can
connect without SSL, but not able to connect with SSL even though nmap
shows that port 636 is listening. In fact I can connect using openssl,
which reveals it's a self-signed cert.
481b8eedcc884289756246e12d1869c1?d=identicon&s=25 Francis Cianfrocca (blackhedd)
on 2007-05-14 13:33
(Received via mailing list)
On 5/10/07, Amos <a.goo0h@gmail.com> wrote:
>
> Has anybody gotten Net/LDAP (0.4) to work with AD over SSL? I can
> connect without SSL, but not able to connect with SSL even though nmap
> shows that port 636 is listening. In fact I can connect using openssl,
> which reveals it's a self-signed cert.
>
>
>

At least one of my commercial clients has done exactly this. Are you
sending
the correct encryption parameters to Net::LDAP#new/#open? Also, if you
get
the head revision of Net::LDAP from rubyforge, you'll find that
Kouhei Sutou has added support for the LDAP STARTTLS verb (documentation
is
in the rdoc). This of course eliminates the need for a separate port.
This topic is locked and can not be replied to.