Forum: Ruby on Rails Which version of Ubuntu to use with Rails

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
16f37cd70474d1c3bd053efbff36d0de?d=identicon&s=25 denisa (Guest)
on 2007-05-09 00:19
(Received via mailing list)
Hello,

This is a question for folks who are using Ubuntu to host your Rails
apps.  Which version of Ubuntu do you use?

Do you use the 'Dapper' release (6.0.6) perhaps due to the long term
support (LTS), or are you using the latest release 'Feisty' (7.0.4)?

Or maybe a better way to ask the question is, is there a preferred
version of Ubuntu to use with Ruby and Rails?

Thanks,
denisa
F3dc06f587d1ff4c7366b102bfda9204?d=identicon&s=25 David Mitchell (Guest)
on 2007-05-09 00:32
(Received via mailing list)
I've been using 6.06 with Rails since it came out, and it works fine
once you get all the bits installed.  I can't recall the exact
details, but there was some messing around with packages in order to
get everything installed correctly.  It didn't take long to resolve,
but it wasn't as simple as it could have been.

I've got a 7.04 box that I'll move to when I get around to it.

Either way, I don't think you'll have problems with Ubuntu and Rails.

Regards

Dave M.
F0987c97234fa9c6b26f796bdbdab037?d=identicon&s=25 werdnativ (Guest)
on 2007-05-09 11:15
(Received via mailing list)
I use Dapper, only because slicehost's installer has that version.
Dapper can install everything you need to run rails, but the ease of
it depends on your chosen deployment stack. Dapper's apt sources
doesn't include apache 2.2 which you'll need for proxying to mongrel,
so that has to be built from source. I'm pretty sure Feisty has apache
2.2 as a packaged installer.

deprec (gem install deprec) can build apache for you on Dapper, and it
works well.

--Andrew Vit
8d1e089fd6a6703f5f13dbee271aa77c?d=identicon&s=25 Yuri Leikind (Guest)
on 2007-05-09 11:39
(Received via mailing list)
Hi,

It all depends on your deployment variant.
I developed on 6.10, now developing on 7.04, and the server is running
Debian 4.0.
My deployment solution is pound + mongrel_cluster.

Cheers,
Yuri

On 5/9/07, werdnativ <andrew@avit.ca> wrote:
>
> > support (LTS), or are you using the latest release 'Feisty' (7.0.4)?
> >
> > Or maybe a better way to ask the question is, is there a preferred
> > version of Ubuntu to use with Ruby and Rails?
> >
> > Thanks,
> > denisa
>
>
>
>


--
Best regards,
Yuri Leikind
A84d51d60791f8e0fb6d27a8a8b2a96e?d=identicon&s=25 Neil Wilson (neilw)
on 2007-05-09 20:48
(Received via mailing list)
AFAIK Feisty is the first version to include Apache 2.2 under 'apt'
control. You need 2.2 to do load balancing properly with mongrel.
Aad37b5f7116c8d1f547d23b37566032?d=identicon&s=25 Greg Donald (destiney)
on 2007-05-09 20:54
(Received via mailing list)
On 5/9/07, Neil Wilson <aldursys@gmail.com> wrote:
>
> AFAIK Feisty is the first version to include Apache 2.2 under 'apt'
> control. You need 2.2 to do load balancing properly with mongrel.


There are plenty of Apache alternatives for load balancing.  I've had
good success with nginx and pound specifically:

http://nginx.net/

http://www.apsis.ch/pound/



--
Greg Donald
http://destiney.com/
This topic is locked and can not be replied to.