Forum: Ruby on Rails OPENid problem with trust_root when rails app running behind

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
60b2a5127d21eb189799cecaad092db9?d=identicon&s=25 (Guest)
on 2007-05-07 19:54
(Received via mailing list)
Hi I am in the process of setting up open id for my website and there
is one thing that I just cannot figure out.

When I run it on my development instance I get it working with out a
problem but when I run it on my production I have a problem with my
trustroot. This is what I get on the open id provider side.

Not under trust_root u'' the trusted root should
be the domain it's coming from I assume.
I suspect this is happening because I am using apache to load balance
between a couple of mongrel instances. I have been trying to set the
trust_root manually but cannot wrap my head around how that is done.

Any ideas?
This topic is locked and can not be replied to.