Forum: GNU Radio unknown protocol class usrp-server-cs

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Ac73d95c8ccddff9ecae369bcb80a923?d=identicon&s=25 George Nychis (Guest)
on 2007-04-23 06:18
(Received via mailing list)
Okay, I can't seem to get past this one which is blocking my progress.

I understand that usrp-server-cs and usrp-tx ... etc are all defined in
usrp_server.mbh file which gets translated to which
is built.

According to the inband, it should be included in the inband

libinband_la_SOURCES =      \
   $(BUILT_SOURCES)    \   <----------- here

checking the output of make, it is included in the library:
ar cru .libs/libinband.a .libs/usrp_server_mbh.o .libs/usrp_server.o

And I am linking my qa code to this library:
libinband_qa_la_LIBADD =    \    \

However I still get this error:
uncaught exception of type std::runtime_error
- mb_port: unknown protocol class 'usrp-server-cs'

What am I missing here?  Do I need to register the usrp_server class as
mblock class somehow?  I tried REGISTER_MBLOCK_CLASS() to no avail.


- George
This topic is locked and can not be replied to.