Forum: Ruby on Rails yajb breaks when i upgrade to rails 1.2

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
8889b05b9f25f84e2e6f8e66b5441155?d=identicon&s=25 stewbawka (Guest)
on 2007-04-12 16:44
(Received via mailing list)
My awesome java bridge solution has been rendered useless when i
upgrade my rails. i've frozen rails to the old version for now, but am
in desperate need of a solution.

details: worked fine before, but since updating rails yajb messes up
the routing of my rails app AND breaks activesupport.

I've heard a couple people crying about this problem after doing some
googling, but i haven't heard any solutions.

is it a problem with yajb (which devel has unfortunately halted) or is
it a problem with the new version of rails?

I tried rjb before, but i was getting some bizarre results from
calling some java api.. it is also a pain to use because you have to
declare your objects types by pointing it to the specific library. and
calling overloaded methods is a huge pain in the ass.

How is jruby coming along? i was considering this a while back when i
first started into this project, but heard that it isn't really ready
for running rails (especially beyond 1.2)..

I also tried putting my yajb stuff in a BackgrounDRB worker.. i
learned some cool BackgroundDRB stuff in the process, but as soon as i
started trying to add in the yajb stuff it broke!

HELP!

Stuart
38a02bf7121a81be5be6f3d488ce23b5?d=identicon&s=25 Alexey Verkhovsky (Guest)
on 2007-04-12 19:16
(Received via mailing list)
jRuby trunk is at the stage where you can, in principle, run a Rails
application on it. It's somewhat slower than CRuby (not drastically
so), and you may hit a couple of bugs in the not-so-obvious corners.

It's a very active project right now, with some people working on it
full time, and the  developers maillist traffic approaching Rails-talk
levels, so bugs get fixed pronto :)

If I were you, I'd give it a try now (to make sure that any bugs you
may care about get spotted and fixed before 1.0 release), and expect
to roll it out to production some time in June.

--
Alex
8889b05b9f25f84e2e6f8e66b5441155?d=identicon&s=25 stewbawka (Guest)
on 2007-04-12 21:53
(Received via mailing list)
thanks for the reply.. i think i will try out jruby very soon. right
now i'm on a tight deadline and am pushing ahead with yajb with frozen
rails. nice to know that at least jruby is being actively developped
unlike yajb and rjb.

so does anybody know what the deal is with yajb and new versions of
rails? should i give up?

Stuart


On Apr 12, 2:15 pm, "Alexey Verkhovsky" <alexey.verkhov...@gmail.com>
21f7ed21f11a809050594c82eab11d67?d=identicon&s=25 Robert Walker (Guest)
on 2007-04-12 22:15
(Received via mailing list)
Sounds to me like you've already made the right decision.  The Rudy on
Rails team has no obligation to ensure that changes to Rails don't
break third party add-ons or plug-ins.  It's completely up to the plug-
in developer to keep up with Rails.  They sure don't want to hold back
Rails development to support everyone's plug-ins.

This is the case with any foundational operating environment.  It's up
to the developer to test their application, and dependencies to plug-
ins, throughly before adopting a new framework version.  And if
dependent plug-ins are not supporting the new framework, then you must
continue using the older framework version.

If that plug-in's development has halted, it's time to start shopping
for other options.

I do agree that if you are dependent on Java then JRuby will be your
best bet for the future.
This topic is locked and can not be replied to.