Forum: GNU Radio problem configuring gr-video-sdl on Cygwin

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
5d6a270d2a6bc37838d963202d090061?d=identicon&s=25 Walker, Robert CIV NAVSURFWARCENDIV Crane, Code (Guest)
on 2007-04-12 15:16
(Received via mailing list)
I am having the same gr-video-sdl problem reported in the message below
when running ./configure for gnuradio-3.0.3 on Cygwin:

The replies pointed out a problem with alloca.h and Cygwin but I didn't
understand the proposed solution.  Can someone elaborate?  There appear
to be links to a patch but I have no idea what to do with it.

A related issue I had is that before I even got to the point above,
there was a problem with the fact that SDL was not installed on my
machine.  I went back through the "Installing GNU Radio with Cygwin"
installation instructions and noticed there is no mention of installing
SDL.  Is this an oversight?  I tried following the SDL installation
instructions on the "Installing GNU Radio with MinGW" page and that got
me to the point of the alloca.h error.  If someone has a solution, any
chance correct SDL installation instructions could be added to the
Cygwin page?

One final thing is that I noticed the ./configure command line options
on the GNU Radio MingW installation page included mention of SDL in a
couple of places.  Those command line options follow for reference:

  CPPFLAGS="-I/usr/local/include -I/usr/local/include/SDL"

Does ./configure in Cygwin need similar SDL-related command line


This topic is locked and can not be replied to.