Forum: Ruby rake segmentation fault

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
998dcd37297540b08b20a6558c40ec64?d=identicon&s=25 Zouplaz (Guest)
on 2007-04-10 23:31
(Received via mailing list)
Hello, I have a problem not directly related with the language itself
but (maybe) with rake : I get a segfault when running rake:functionals
since I've updated my system (to rails 1.2.2 and rake 0.7.2)
I don't have any idea about the file causing the seg fault, I just see
that the seg fault occurs, without any clue.

oaded suite
/usr/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake/rake_test_loader
Started
................(eval):5: [BUG] Segmentation fault
ruby 1.8.4 (2005-12-24) [i386-linux]

rake aborted!
Command failed with status (): [/usr/bin/ruby -Ilib:test
"/usr/lib/ruby/ge...]

(See full trace by running task with --trace)

Using --trace gives some more :

Command failed with status (): [/usr/bin/ruby -Ilib:test
"/usr/lib/ruby/ge...]
/usr/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:730:in `sh'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:737:in `sh'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:816:in `sh'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:811:in `sh'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:751:in `ruby'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:816:in `ruby'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:811:in `ruby'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake/testtask.rb:117:in
`define'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:835:in `verbose'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake/testtask.rb:102:in
`define'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:399:in `execute'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:399:in `execute'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:369:in `invoke'
/usr/lib/ruby/1.8/thread.rb:135:in `synchronize'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:362:in `invoke'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:1935:in `run'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:1935:in `run'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.2/bin/rake:7
/usr/bin/rake:16


I've tried to run each individual test, none of them produced a seg
fault.

Ruby version is 1.8.4 (CentOS, the OS I'm using don't provide an
official 1.8.6 release)

BTW, does anybody knows about a CentOS (Redhat Ent Server) compatible
package ? Thanks

Thanks
753dcb78b3a3651127665da4bed3c782?d=identicon&s=25 Brian Candler (Guest)
on 2007-04-11 07:15
(Received via mailing list)
On Wed, Apr 11, 2007 at 06:30:08AM +0900, Zouplaz wrote:
> Ruby version is 1.8.4 (CentOS, the OS I'm using don't provide an
> official 1.8.6 release)
>
> BTW, does anybody knows about a CentOS (Redhat Ent Server) compatible
> package ? Thanks

http://dev.centos.org/centos/4/testing/i386/RPMS/
gives you 1.8.5, so maybe that's worth a try.
This topic is locked and can not be replied to.