Forum: Radiant CMS Troubles in radiant installation on windows

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
145e373624d173d2226a3dec4c563dfe?d=identicon&s=25 Jack Tang (Guest)
on 2007-04-08 19:35
(Received via mailing list)
Hi,

I am new to radiant and try to install it and learn something from it.
So I followed the introductions from wiki and blog:

http://dev.radiantcms.org/radiant/wiki/Installation
http://radiantcms.org/blog/

Both 0.6.0rc2 and code from subversion I have tried, and the same
errors came out:

D:\test\myapp>rake production db:bootstrap --trace
(in D:/test/myapp)
** Invoke production (first_time)
** Execute production
** Invoke environment (first_time)
** Execute environment
rake aborted!
wrong number of arguments (1 for 0)
c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/vendor/rails/activerecord/lib/activ
e_record/vendor/mysql.rb:566:in `initialize'
c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/vendor/rails/activerecord/lib/activ
e_record/vendor/mysql.rb:566:in `new'
c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/vendor/rails/activerecord/lib/activ
e_record/vendor/mysql.rb:566:in `scramble41'
c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/vendor/rails/activerecord/lib/activ
e_record/vendor/mysql.rb:144:in `real_connect'
c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/vendor/rails/activerecord/lib/activ
e_record/connection_adapters/mysql_adapter.rb:389:in `connect'
c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/vendor/rails/activerecord/lib/activ
e_record/connection_adapters/mysql_adapter.rb:152:in `initialize'
c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/vendor/rails/activerecord/lib/activ
e_record/connection_adapters/mysql_adapter.rb:82:in `new'
c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/vendor/rails/activerecord/lib/activ
e_record/connection_adapters/mysql_adapter.rb:82:in `mysql_connection'
c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/vendor/rails/activerecord/lib/activ
e_record/connection_adapters/abstract/connection_specification.rb:262:in
`send'
c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/vendor/rails/activerecord/lib/activ
e_record/connection_adapters/abstract/connection_specification.rb:262:in
`connec
tion_without_query_cache='
c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/vendor/rails/activerecord/lib/activ
e_record/query_cache.rb:54:in `connection='
c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/vendor/rails/activerecord/lib/activ
e_record/connection_adapters/abstract/connection_specification.rb:230:in
`retrie
ve_connection'
c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/vendor/rails/activerecord/lib/activ
e_record/connection_adapters/abstract/connection_specification.rb:78:in
`connect
ion'
c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/lib/radiant/initializer.rb:41:in
`i
nitialize_extensions'
c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/lib/radiant/initializer.rb:36:in
`a
fter_initialize'
c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/vendor/rails/railties/lib/initializ
er.rb:114:in `process'
c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/vendor/rails/railties/lib/initializ
er.rb:43:in `send'
c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/vendor/rails/railties/lib/initializ
er.rb:43:in `run'
c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/lib/radiant/initializer.rb:32:in
`r
un'
D:/test/myapp/config/../config/environment.rb:15
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_re
quire'
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/vendor/rails/railties/lib/tasks/mis
c.rake:3
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:399:in `call'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:399:in `execute'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:399:in `each'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:399:in `execute'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:369:in `invoke'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:362:in
`synchronize'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:362:in `invoke'
c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/lib/tasks/environments.rake:10
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:399:in `call'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:399:in `execute'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:399:in `each'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:399:in `execute'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:369:in `invoke'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:362:in
`synchronize'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:362:in `invoke'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:1935:in `run'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:1935:in `each'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.2/lib/rake.rb:1935:in `run'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.2/bin/rake:7
c:/ruby/bin/rake.bat:20:in `load'
c:/ruby/bin/rake.bat:20

I used mysql as backend and my ruby version is ruby 1.8.6 (2007-03-13
patchlevel 0) [i386-mswin32], rails is 1.2.3. Could you please help me
out? Thanks!

Regards

/Jack


--
Keep Discovering ... ...
http://jack.lifegoo.com
6ec6f77ea603dd75b3a7a7775b059e79?d=identicon&s=25 John W. Long (Guest)
on 2007-04-09 16:26
(Received via mailing list)
Jack Tang wrote:
> wrong number of arguments (1 for 0)
> c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/vendor/rails/activerecord/lib/activ
> e_record/vendor/mysql.rb:566:in `initialize'

That is really strange. It looks like you are having problems with the
mysql driver. Did you install using the One-Click installer? If not do
you know whether or not you are using the ruby-based mysql drivers or
the C-ruby mysql drivers?

Any Windows users care to give Jack a hand?

--
John Long
http://wiseheartdesign.com
145e373624d173d2226a3dec4c563dfe?d=identicon&s=25 Jack Tang (Guest)
on 2007-04-09 16:39
(Received via mailing list)
On 4/9/07, John W. Long <ng@johnwlong.com> wrote:
> > rake aborted!
> > wrong number of arguments (1 for 0)
> > c:/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.0/vendor/rails/activerecord/lib/activ
> > e_record/vendor/mysql.rb:566:in `initialize'
>
> That is really strange. It looks like you are having problems with the
> mysql driver. Did you install using the One-Click installer?

Yes, I did install using the One-Click installer

> If not do
> you know whether or not you are using the ruby-based mysql drivers or
> the C-ruby mysql drivers?

Ruby-based mysql driver. And it works fine in my own rails application.


>
--
Keep Discovering ... ...
http://jack.lifegoo.com
6ec6f77ea603dd75b3a7a7775b059e79?d=identicon&s=25 John W. Long (Guest)
on 2007-04-09 16:53
(Received via mailing list)
Jack Tang wrote:
> Ruby-based mysql driver. And it works fine in my own rails application.
What does your config/database.yml look like?

--
John Long
http://wiseheartdesign.com
145e373624d173d2226a3dec4c563dfe?d=identicon&s=25 Jack Tang (Guest)
on 2007-04-09 17:26
(Received via mailing list)
after run "radiant -d mysql myapp", the dabase.yml file is generated.
=========================================================
# MySQL (default setup).  Versions 4.1 and 5.0 are recommended.
#
# Install the MySQL driver:
#   gem install mysql
# On MacOS X:
#   gem install mysql -- --include=/usr/local/lib
# On Windows:
#   There is no gem for Windows.  Install mysql.so from RubyForApache.
#   http://rubyforge.org/projects/rubyforapache
#
# And be sure to use new-style password hashing:
#   http://dev.mysql.com/doc/refman/5.0/en/old-client.html
development:
  adapter: mysql
  database: myapp_development
  username: root
  password:
  host: localhost

# Warning: The database defined as 'test' will be erased and
# re-generated from your development database when you run 'rake'.
# Do not set this db to the same as development or production.
test:
  adapter: mysql
  database: myapp_test
  username: root
  password:
  host: localhost

production:
  adapter: mysql
  database: myapp_production
  username: root
  password:
  host: localhost



On 4/9/07, John W. Long <ng@johnwlong.com> wrote:
> >
> Search: http://radiantcms.org/mailing-list/search/
> Site:   http://lists.radiantcms.org/mailman/listinfo/radiant
>


--
Keep Discovering ... ...
http://jack.lifegoo.com
B03a63f9294524418ac4d486f567323c?d=identicon&s=25 Captain Feng (lumao66)
on 2007-04-28 05:20
Follow the instruction of the article(http://radiantcms.org/download/),
and that will help you to fix you problems.

regards.
captain
145e373624d173d2226a3dec4c563dfe?d=identicon&s=25 Jack Tang (Guest)
on 2007-04-28 06:45
(Received via mailing list)
On 4/28/07, Captain Feng <fengyu8299@gmail.com> wrote:
> Follow the instruction of the article(http://radiantcms.org/download/),
> and that will help you to fix you problems.
>
> regards.
> captain

Yes, I tried yesterday. It worked great! Thanks.

> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> Radiant mailing list
> Post:   Radiant@lists.radiantcms.org
> Search: http://radiantcms.org/mailing-list/search/
> Site:   http://lists.radiantcms.org/mailman/listinfo/radiant
>


--
Keep Discovering ... ...
http://jack.lifegoo.com
This topic is locked and can not be replied to.