Forum: Rails deployment Fw: Capistrano problem deploying to production database only

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
8f977c0870d57e52e488dc3546fb7f24?d=identicon&s=25 Raul (Guest)
on 2007-04-05 20:06
(Received via mailing list)
Oops.  I had other problems that needed fixing first.  I was missing the
net-ssh gem from the gem install net-ssh on all the poroduction servers.

So now I just have a problem getting the migration to work.  I'm still
troubleshooting that myself but just in case here's my command and my

> cap production1 migrate


  * executing task production1
  * executing task migrate
  * executing "cd /website/bankspower/current && rake
    servers: ["172.x.x.x"]
Password: ***

    [172.x.x.x] executing command
 ** [out :: 172.x.x.x] (in /website/bankspower/releases/20070405175714)
 ** [out :: 172.x.x.x]
.rb:29:Warning: require_gem is obsolete.  Use gem instead.
 ** [out :: 172.x.x.x] rake aborted!
 ** [out :: 172.x.x.x] Mysql::Error: Table
 doesn't exist: SELECT version FROM schema_info
 ** [out :: 172.x.x.x]
** [out :: 172.x.x.x] (See full trace by running task with --trace)
    command finished
command "cd /website/bankspower/current && rake RAILS_ENV=production
" failed on 172.x.x.x

Anyway, still working on it.



----- Original Message -----
From: "Raul" <>
To: <>
Sent: Thursday, April 05, 2007 8:36 AM
Subject: Capistrano problem deploying to production database only server
This topic is locked and can not be replied to.