Forum: Ruby on Rails Problem with loading acts_as_authenticated plugin

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
B1415e872f86d771167c48a0832f583b?d=identicon&s=25 Laurent (Guest)
on 2007-04-04 09:53
(Received via mailing list)
I currently develop a little app, and i installed the
acts_as_authenticated plugin
Everything worked fine til yesterday evening. While working on CSS
sheet, then testing iteratively : nothing worked.
Checking the development.log file in my Rails app , it shows:

NameError (uninitialized constant
ApplicationController::AuthenticatedSystem):
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/
dependencies.rb:477:in `const_missing'

It comes from the :
include AuthenticatedSystem
declared in my application.rb file (inside the class)

When commenting it, no more problems.

It seems the plugin's libraries are not loaded.
Wht i do not understand, is i have another plugin installed :
acts_as_taggable, which works perfectly.

After searching with Google, i had some configurations tricks in
environment.rb >
Dependencies.log_activity = true
Dependencies.autoloaded_constants
Dependencies.load_once_paths

But nothing changes

Any help is needed

PS : my environment is :
Mac OS X 10.4.9
Ruby 1.8.2
Rails 1.2.3


Laurent
B1415e872f86d771167c48a0832f583b?d=identicon&s=25 Laurent (Guest)
on 2007-04-06 07:52
(Received via mailing list)
I resolved the problem with the help of some folks on irc.
In fact, after several reinstallation of the plugin, i should run the
script :
./script/generate authenticated user account

It should create a folder /lib into : /vendor/plugins/
acts_as_authenticated, including the authenticated_system.rb file

But, this folder has been created in the /log folder.
Moving the lib folder to the plugin root folder did the trick.

Laurent
This topic is locked and can not be replied to.