Forum: Ruby on Rails http_authentication plugin on edge rails

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
0e7d5331c8315f1cdba91506ed360195?d=identicon&s=25 (Guest)
on 2007-04-01 02:07
(Received via mailing list)
I'm trying to use the http_authentication plugin with edge rails, and
I'm getting an error that I'm not sure how to deal with. I just added
the code from the example to one of my controllers, and it's throwing
the following error:

protected method `render' called for #<SuggestionsController:

http_authentication/basic.rb:49:in `authentication_request'
http_authentication/basic.rb:17:in `request_http_basic_authentication'
/usr/local/bin/mongrel_rails:16:in `load'

It's having an issue creating/rendering the authentication box that
would let you put in the password.
I'm wondering if anyone else is trying to use this on edge, and could
offer some suggestions.

40db9e75b3f5899258e3bdc0c9210154?d=identicon&s=25 Conrad Taylor (Guest)
on 2007-04-01 02:11
(Received via mailing list)
Hi, how did you install the plugin?  What were you attempting to do to
generate the error message?  This information will help others help

0e7d5331c8315f1cdba91506ed360195?d=identicon&s=25 (Guest)
on 2007-04-01 18:47
(Received via mailing list)
I installed the plugin using "piston import vendor/

The error popped up when I went to,
which invoked the index method on the suggestions controller which I
have protected.

When I installed the plugin the same way on an earlier version of
rails (1.1.6 I believe) I didn't get the error, but just the response
"HTTP Basic: Access denied." without an option to log in.
0e7d5331c8315f1cdba91506ed360195?d=identicon&s=25 (Guest)
on 2007-04-01 19:15
(Received via mailing list)
I just created a test project with rails 1.2.3 and the plugin works
exactly as I would expect it to, so I believe this is an issue with
the interaction with edge rails. I understand that that it might be
failed because something that has been added or removed, so again, I'm
just asking to see if anyone else is currently using it in that
capacity. I'd like to continue to develop this site using edge, but
I'll drop back to 1.2.3 if I must.

This topic is locked and can not be replied to.