Forum: Rails deployment Moving Application from Windows WEBrick to Linux Apache host

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
78d17eda31083a8f1d67e6f81cc1e9eb?d=identicon&s=25 david (Guest)
on 2007-03-26 19:33
I have some kind of problem. I was trying to upload sample application
to my hosting which supports RoR 1.2 and I have a lot of problems. I
just can't start the application. I don't have SSH access to it.

There are three files which depends on the system:

I changed path to correct one, on the Linux machine. I changed to use it
fast CGI.
From dispatcg.fcgi:
require 'fcgi_handler'
require 'fcgi'
require 'rubygems'
require_gem 'fcgi'

From .htaccess:
RewriteRule ^(.*)$ dispatch.fcgi [QSA,L]

All three files have 755 permission.

I uncommented this line: ENV['RAILS_ENV'] ||= 'production'

I changed tmp directory permission to 777.

For some testing purposes I was using CGI: (website:

[Mon Mar 26 08:53:45 2007] [error] [client] Premature end
of script headers: /home/davidlt/public_html/portal/public/dispatch.cgi

or FastCGI:

[Mon Mar 26 10:27:33 2007] [warn] FastCGI: (dynamic) server
"/home/davidlt/public_html/portal/public/dispatch.fcgi" has failed to
remain running for 30 seconds given 3 attempts, its restart interval has
been backed off to 600 seconds

Any ideas why it is still not working?..
This topic is locked and can not be replied to.