Forum: Ruby Code completion for Ruby - Net Beans, RDT, and more

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
3c4fdd7b08eeba9bb563a0cb3e53be50?d=identicon&s=25 Robert J. (robertjames)
on 2007-03-22 22:40
(Received via mailing list)
Code completion for Ruby is on its way.  I'm concerned that the
recently popular  style of using hashes to fake named params will keep
us in the dark, though.

And anyway, Ruby wants to get named params.  How about this: declare
the method explicitly:

def parse(filename, char = nil, conn = nil, another_param = nil)

and have the interpreter allow the style, by converting a final hash
to params if and only if all of the keys match the arg names.

So:

parse('readme.txt', :char => 'a', :another_param => true)
becomes
parse('readme.txt', a, nil, true)

whereas
parse('readme.txt', :bad_param => 'b')
would still be
parse('readme.txt', {:bad_param => 'b'})
and it would be up to the parse method to handle as it normally does.

This would allow:
* real named params
* more explicit method definitions
* code completion
* preserve the current style
Patrick Hurley (Guest)
on 2007-03-22 22:58
(Received via mailing list)
On 3/22/07, S. Robert James <srobertjames@gmail.com> wrote:
> to params if and only if all of the keys match the arg names.
> parse('readme.txt', {:bad_param => 'b'})
> and it would be up to the parse method to handle as it normally does.
>
> This would allow:
> * real named params
> * more explicit method definitions
> * code completion
> * preserve the current style
>
>
>

Named parameters is in the ToDo file on 1.9 distribution:

* named arguments like foo(nation:="german") or foo(nation: "german").


so you may get what you want
pth
3c4fdd7b08eeba9bb563a0cb3e53be50?d=identicon&s=25 Robert J. (robertjames)
on 2007-03-22 23:21
(Received via mailing list)
Right - I should clarify - my goal is to allow easy migration of all
of the current libs that use option hashes.

With the syntax I'm suggesting, library owners could change their
method definitions, and not break older code.
This topic is locked and can not be replied to.