Forum: Radiant CMS mongrel and radiant

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
9c2bf699672a447d8ac17c589279faed?d=identicon&s=25 Fabrizio Taddei (buzman1)
on 2007-03-14 10:52
(Received via mailing list)
Hi
Everybody,
I'm a newbie of Radiant. I' ve developed a simple application
and now I'd like to deploy it on my windows server.
I've installed APACHE
2.2, MONGREL, MONGREL_SERVICE as the book "Agile web development with
rails"
suggests.
Unfortunately I  haven't any
success.
When I try to create a mongrel service running
this command:
>mongrel_rails service::install -e production -p 4000 -c
d:\ProveRails\radiant06

I  receive this error

!!! The path
you specified isn't a valid Rails application.
service::install reported an
error. Use mongrel_rails service::install -h to get help.

If I start mongrel with the command:
>mongrel_rails start -e production -p 4001 -c d:\ProveRails\radiant06
it's work normally.

Can you help
me?
Is this a  right way to deploy Radiant
application?
Do you have any suggestion  about how can I
simply deploy my Radiant application?

Thank's everyboby
Taddei Fabrizio








___________________________________
L'email della prossima generazione? Puoi averla con la nuova Yahoo!
Mail:
http://it.docs.yahoo.com/nowyoucan.html
Efd869eb4ba0163bfffe51f8a62d0e59?d=identicon&s=25 Martin McEvoy (Guest)
on 2007-03-14 13:08
(Received via mailing list)
On Wed, 2007-03-14 at 09:50 +0000, Fabrizio Taddei wrote:
> Hi Everybody,
> I'm a newbie of Radiant. I' ve developed a simple application and now
> I'd like to deploy it on my windows server.
> I've installed APACHE 2.2, MONGREL, MONGREL_SERVICE as the book "Agile
> web development with rails" suggests.
> Unfortunately I  haven't any success.
> When I try to create a mongrel service running this command:
> >mongrel_rails service::install -e production -p 4000 -c d:\ProveRails
> \radiant06

try cd d:\ProveRails\radiant06

mongrel_rails service::install -N radiant -p 4000 -e production

mongrel_rails service::start -N radiant

:)
2832818dc0c73ce86d72d491328b9c53?d=identicon&s=25 Luca Narbone (lucanarbone)
on 2007-07-25 15:42
Hi!

I have the same error message: I tryed to run service::install from the
directory as written in the reply but I get the same error message
again! And tryed with two different radiant applications too!

Maybe it's because the structure of the app folder in a radiant app is
different from the one of a standard rails app??

Please need help!
2085e4cc965a645a2d2036acb296390f?d=identicon&s=25 Mariano Viola (Guest)
on 2007-07-26 00:45
(Received via mailing list)
Hi,

add the "app" folder to the tree of your radiant site, it work fine for
me.
Good luck!

Mariano

On 7/25/07, Luca Narbone <luca.narbone@gmail.com> wrote:
> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> Radiant mailing list
> Post:   Radiant@lists.radiantcms.org
> Search: http://radiantcms.org/mailing-list/search/
> Site:   http://lists.radiantcms.org/mailman/listinfo/radiant
>


--
Mariano Viola
Lead Interaction Designer at
MockupLab - Communication Design
http://www.mockuplab.com
This topic is locked and can not be replied to.