Forum: Ruby on Rails Mongrel on Windows Server 2003 Results in 500 Errors

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
1ffec6d10bec4303b1cc4d6930169ea4?d=identicon&s=25 Codemonk (Guest)
on 2007-03-13 00:20
(Received via mailing list)
Ok, here is the situation:

I need to run a mongrel server on windows server 2003. The application
it will be serving is an application that is frozen to rails 1.1.6.

We're using mongrel 1.0 as the web server.

Every 10th request (random, sometimes more sometimes less), either
called through ajax or as a normal page request... dies with a 500
error. No logs are available anywhere, as far as the app is concerned
it's behaving normally.

We are running mongrel "as a service".

The parameters of the service are as follows:
"c:/ruby/bin/mongrel_service.exe" single -e development -p 80 -a
0.0.0.0 -l "log/mongrel.log" -P "log/mongrel.pid" -c "c:/webapps/
myapp" -t 0 -r "public" -n 1024
8bc543795b502900b5333aea73ad5533?d=identicon&s=25 Eden Li (edenli)
on 2007-03-14 03:50
(Received via mailing list)
You might want to ask this question of mongrel-users@rubyforge.org
6ef8cb7cd7cd58077f0b57e4fa49a969?d=identicon&s=25 Brian Hogan (Guest)
on 2007-03-14 04:00
(Received via mailing list)
My guess is a poorly configured application. We run Mongrel on those
specs
on at lest 10 apps with no problems whatsoever.

What type of db are you using? Is it MySQL? MySQL has issues on Windows
that
you need to address - you need a much better adapter like the mysql gem
or
the MySQL Ruby bindings. If you don't have that you'll get those random
500
errors.
This topic is locked and can not be replied to.