Forum: Rails deployment How to set '302 Moved' location protocol

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
2b891e820c238ded365d035771603f21?d=identicon&s=25 Bill Walton (Guest)
on 2007-03-09 23:46
(Received via mailing list)
Same problem, but hopefully a clearer call for help ;-)

I need to set the protocol part of the Location: in the '302 Moved'
header to 'https:'.  I can see in Live HTTP Headers that it's currently
set to 'http:'.  This is causing warning dialogs ('you're being
redirected to an unsecured page') under SSL for all my controller to
controller redirect_to's.  Is this something I can set in Rails?  Or is
it something that gets set somewhere else (like Apache, maybe?).

Thanks much for any help!!!

Best regards,
Bill
Df5e7adb20adae6c120b04e7cafb15a0?d=identicon&s=25 Rob Sanheim (rsanheim)
on 2007-03-10 00:29
(Received via mailing list)
On 3/9/07, Bill Walton <bill.walton@charter.net> wrote:
>
> Thanks much for any help!!!
>
> Best regards,
> Bill

There are a ton of discussions already on this -- this was at the top
of google's list:

http://blog.duncandavidson.com/2006/01/reverse_proxyin.html
also
http://dev.rubyonrails.org/ticket/5346

- Rob
2b891e820c238ded365d035771603f21?d=identicon&s=25 Bill Walton (Guest)
on 2007-03-10 01:51
(Received via mailing list)
Hi Rob,

First, thank you very much for your reply.  I really appreciate it and,
after taking a quick look at the first link, am feeling pretty sure
it'll
help me figure out what I need to do.  Second thing is, I have no idea
wtf a
'reverse proxy' is.  Which is why I'm so very thankful to Robby for
setting
this list up to begin with.

Thanks again for your reply. At least now I have something to Google on.
Damn tough to find an answer when you can't even form a good question
;-)

Best regards,
Bill
This topic is locked and can not be replied to.