Forum: Ruby on Rails what happens when "rake test"?

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
F78258e63d2879413ebf4558d74c1a9e?d=identicon&s=25 Kevin Yang (Guest)
on 2007-03-08 10:35
(Received via mailing list)
    I meet a problem which become a stopper. When I run "rake test" .
then there always comes the error :

D:/InstantRails/ruby/lib/ruby/1.8/csv.rb:11: CSV is not a class

my enviroment is Rails1.2.1+Ruby1.8.4. The same issue can be
reproduced in the same code in Rails1.2.2+Ruby1.8.5

currently i can comments this then all works.

\fixtures.rb (line 3)
    require 'csv'

but what i think this is a damage to the project.

what I am interested is , what happens when i run "rake test"?  i
would like to debug into the source code to see what is going on and
why there is such bug.


This topic is locked and can not be replied to.