Forum: Ruby on Rails Capistrano put

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
A39bc22e80090ca10bf55ecb4bb68fed?d=identicon&s=25 stemey (Guest)
on 2007-03-05 09:04
(Received via mailing list)

I have tried to use "put" in my capistrano task to upload a zip file.
Unfortunately it gets corrupted. This is the code:

    :mode => 0444)

Do I have to set a parameter saying that it is a binary file? The
local server is a windows box and the remote ones are linux/debian.

40db9e75b3f5899258e3bdc0c9210154?d=identicon&s=25 Conrad Taylor (Guest)
on 2007-03-05 09:26
(Received via mailing list)
Hey Stefan, could you provide a transcript of the error message that
you're receiving?

11ba36dcbe955d1f2c4111de906134c4?d=identicon&s=25 Lori Olson (Guest)
on 2007-03-05 18:24
(Received via mailing list)
Quick fix... Delete the destination file first.

delete "/home//releases/current/"put(
    :mode => 0444)

That fixed it for me.

Regards, Lori
This topic is locked and can not be replied to.