WEBrick and OS X 10.4.5 problems?

Has anyone who is running OS X 10.4.5 and the security patches
thereafter noticed that WEBrick is no longer functioning? I have a
machine at school that I believe to be patched with 10.4.5 but not
with the latest security patch and WEBrick seems to run fine for it.
However, on my machine at home I can’t get WEBrick to successfully
run even freshly generated apps.

For both valid and invalid actions WEBrick is returning 500’s, as
opposed to 404’s or 200’s.

127.0.0.1 - - [16/Mar/2006:02:05:04 PST] “GET / HTTP/1.1” 200 7551

  • -> /
    127.0.0.1 - - [16/Mar/2006:02:05:04 PST] “GET /favicon.ico HTTP/1.1”
    200 0
  • -> /favicon.ico
    127.0.0.1 - - [16/Mar/2006:02:05:04 PST] “GET /javascripts/
    prototype.js HTTP/1.1” 200 47603
    http://localhost:3000/ -> /javascripts/prototype.js
    127.0.0.1 - - [16/Mar/2006:02:05:04 PST] “GET /javascripts/effects.js
    HTTP/1.1” 200 30257
    http://localhost:3000/ -> /javascripts/effects.js
    127.0.0.1 - - [16/Mar/2006:02:05:04 PST] “GET /images/rails.png HTTP/
    1.1” 200 1787
    http://localhost:3000/ -> /images/rails.png
    127.0.0.1 - - [16/Mar/2006:02:05:06 PST] “GET /rails_info/properties
    HTTP/1.1” 500 0
    http://localhost:3000/ -> /rails_info/properties
    127.0.0.1 - - [15/Mar/2006:22:05:43 PST] “GET /Mike HTTP/1.1” 500 0
  • -> /Mike
    127.0.0.1 - - [15/Mar/2006:22:05:43 PST] “GET /User HTTP/1.1” 500 0
  • -> /User

Anyone else seen this behavior?

Michael J.
[email protected]

I’ve also tried re-installing from source since the patches and have
had no luck, either.

Michael J.
[email protected]

Has anyone who is running OS X 10.4.5 and the security patches
thereafter noticed that WEBrick is no longer functioning? I have a
machine at school that I believe to be patched with 10.4.5 but not
with the latest security patch and WEBrick seems to run fine for it.
However, on my machine at home I can’t get WEBrick to successfully
run even freshly generated apps.

Works here, but I get an empty page in safari and a functional page in
camino. Try another browser maby? That will eliminate safari.

regards
Claus

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs