# Upgrading on Unix

**URL:** <https://www.ruby-forum.com/t/upgrading-on-unix/196980>\
**Category:** Rails\
**Created:** [July 7, 2009, 3:13pm UTC](https://www.ruby-forum.com/t/upgrading-on-unix/196980 "2009-07-07T15:13:58Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![parki](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/p/b782af/32.png) [@parki](https://www.ruby-forum.com/u/parki)\
**Post date:** [July 7, 2009, 3:13pm UTC](https://www.ruby-forum.com/t/upgrading-on-unix/196980/1 "2009-07-07T15:13:58Z")

</div>

Do I need to re-install gems after upgrading from Ruby 1.8.6 to 1.8.7 on  
Unix?

---

<div class="post-metadata">

**Author:** ![parki](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/p/b782af/32.png) [@parki](https://www.ruby-forum.com/u/parki)\
**Post date:** [July 7, 2009, 4:06pm UTC](https://www.ruby-forum.com/t/upgrading-on-unix/196980/2 "2009-07-07T16:06:10Z")

</div>

Vamsi krishna Kilari wrote:

> Brian,
> 
> Yup you need to re install rubygems and all the gems required.
> 
> Thanks,  
> Kilari.  
> [http://kilari.co.in](http://kilari.co.in)
> 
> Brian P. wrote:
> 
> > Do I need to re-install gems after upgrading from Ruby 1.8.6 to 1.8.7 on  
> > Unix?

Thanks Vamsi…in an attempt to understand things better, just curious  
as to why this is needed? I already had all the latest versions of all  
my gems installed…just updated ruby in /usr/lib/ruby. I’m not  
questioning you’re reply, just trying to gain some knowledge.

Thanks again,  
Brian

---

<div class="post-metadata">

**Author:** ![parki](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/p/b782af/32.png) [@parki](https://www.ruby-forum.com/u/parki)\
**Post date:** [July 7, 2009, 4:37pm UTC](https://www.ruby-forum.com/t/upgrading-on-unix/196980/3 "2009-07-07T16:37:34Z")

</div>

Brian,

/usr/local/lib/ruby/gems/1.6  
/usr/local/lib/ruby/gems/1.7

These are the folders gems are installed(linux).So all your previous  
installation gems will be in the 1.6 folder.What you can do it you can  
simlink 1.7 to 1.6 and it shud work fine.But some cases it might cause  
issues.so I have suggested to reinstall all the gems.

Thanks,  
Kilari.  
[http://kilari.co.in](http://kilari.co.in)

Brian P. wrote:

> Vamsi krishna Kilari wrote:
> 
> > Brian,
> > 
> > Yup you need to re install rubygems and all the gems required.
> > 
> > Thanks,  
> > Kilari.  
> > [http://kilari.co.in](http://kilari.co.in)
> > 
> > Brian P. wrote:
> > 
> > > Do I need to re-install gems after upgrading from Ruby 1.8.6 to 1.8.7 on  
> > > Unix?
> 
> Thanks Vamsi…in an attempt to understand things better, just curious  
> as to why this is needed? I already had all the latest versions of all  
> my gems installed…just updated ruby in /usr/lib/ruby. I’m not  
> questioning you’re reply, just trying to gain some knowledge.
> 
> Thanks again,  
> Brian

---

<div class="post-metadata">

**Author:** ![parki](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/p/b782af/32.png) [@parki](https://www.ruby-forum.com/u/parki)\
**Post date:** [July 7, 2009, 5:06pm UTC](https://www.ruby-forum.com/t/upgrading-on-unix/196980/4 "2009-07-07T17:06:58Z")

</div>

This is actually not the case!

If you are using ruby 1.8.6 OR 1.8.7 your gems will be in gems/1.8  
for example on my Mac: /Library/Ruby/Gems/1.8  
on my Linux: /usr/lib64/ruby/gems/1.8

You will need to reinstall if you upgrade to ruby 1.9  
You will also need to reinstall if you upgrade to REE (ruby enterprise  
edition) since it uses a separate directory too.  
on the same linux ree installation uses /usr/lib64/rubyee/gems/1.8

Note that those installations can coexist on the same machine. they  
use binaries like ruby18, rubyee, ruby19, gem18, gemee, gem19  
with ruby and gem usually being a symlink to one of the above.

Regards

–  
Vitaly Kushner  
[http://twitter.com/vkushner](http://twitter.com/vkushner)  
Founder, Astrails Ltd. [http://astrails.com](http://astrails.com)  
Check out our blog: [http://blog.astrails.com](http://blog.astrails.com)

On Jul 7, 5:37 pm, Vamsi krishna Kilari \<rails-mailing-l…@andreas-

---

<div class="post-metadata">

**Author:** ![parki](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/p/b782af/32.png) [@parki](https://www.ruby-forum.com/u/parki)\
**Post date:** [July 7, 2009, 3:19pm UTC](https://www.ruby-forum.com/t/upgrading-on-unix/196980/5 "2009-07-07T15:19:41Z")

</div>

Brian,

Yup you need to re install rubygems and all the gems required.

Thanks,  
Kilari.  
[http://kilari.co.in](http://kilari.co.in)

Brian P. wrote:

> Do I need to re-install gems after upgrading from Ruby 1.8.6 to 1.8.7 on  
> Unix?

---

<div class="post-metadata">

**Author:** ![parki](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/p/b782af/32.png) [@parki](https://www.ruby-forum.com/u/parki)\
**Post date:** [July 8, 2009, 4:23pm UTC](https://www.ruby-forum.com/t/upgrading-on-unix/196980/6 "2009-07-08T16:23:25Z")

</div>

Brian,

Yup you need to re install rubygems n all the gems.

Thanks,

Kilari.

[http://kilari.co.in](http://kilari.co.in)

On Jul 7, 6:13 pm, Brian P. [removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid)

---

<div class="post-metadata">

**Author:** ![parki](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/p/b782af/32.png) [@parki](https://www.ruby-forum.com/u/parki)\
**Post date:** [July 8, 2009, 8:11pm UTC](https://www.ruby-forum.com/t/upgrading-on-unix/196980/7 "2009-07-08T20:11:10Z")

</div>

hi there wrote:

> If your new version ruby overwrites the old one, you needn’t re-install  
> gems.
> 
> On Tue, Jul 7, 2009 at 9:13 PM, Brian P. \<

Thanks all…I was able to move on w/out re-installing the gems.

---

<div class="post-metadata">

**Author:** ![parki](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/p/b782af/32.png) [@parki](https://www.ruby-forum.com/u/parki)\
**Post date:** [July 8, 2009, 4:23pm UTC](https://www.ruby-forum.com/t/upgrading-on-unix/196980/8 "2009-07-08T16:23:25Z")

</div>

If your new version ruby overwrites the old one, you needn’t re-install  
gems.

On Tue, Jul 7, 2009 at 9:13 PM, Brian P. \<
