# Upgrade to 2.2.2 - problem with existing Localization library

**URL:** <https://www.ruby-forum.com/t/upgrade-to-2-2-2-problem-with-existing-localization-library/155835>\
**Category:** Rails\
**Created:** [December 17, 2008, 10:57am UTC](https://www.ruby-forum.com/t/upgrade-to-2-2-2-problem-with-existing-localization-library/155835 "2008-12-17T10:57:07Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![casper\_the\_ghost](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/c/58956e/32.png) [@casper\_the\_ghost](https://www.ruby-forum.com/u/casper_the_ghost)\
**Post date:** [December 17, 2008, 10:57am UTC](https://www.ruby-forum.com/t/upgrade-to-2-2-2-problem-with-existing-localization-library/155835/1 "2008-12-17T10:57:07Z")

</div>

I upgraded my application to Rails 2.2.2 from 1.2.6 last night.

I encountered a problem with the Localization library (1.0.7) that I  
installed at the time of installing SaltedHashLoginGenerator (requires  
Localization). Error message below. Error occurs when I fire up  
WeBrick.

Is there a new localization feature in Rails 2 that is causing a  
problem?

Thanks!

* * *

/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active\_support/  
dependencies.rb:442:in `load_missing_constant': uninitialized constant Localization::CONFIG (NameError) from /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/ active_support/dependencies.rb:77:in`const\_missing’  
from /home/leelon/workspace/pingi/lib/localization.rb:85  
from /usr/local/lib/site\_ruby/1.8/rubygems/custom\_require.rb:31:in  
`gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in`require’  
from /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/  
active\_support/dependencies.rb:153:in `require' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/ active_support/dependencies.rb:521:in`new\_constants\_in’  
from /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/  
active\_support/dependencies.rb:153:in `require' from /home/leelon/workspace/pingi/app/controllers/application.rb:4 ... 33 levels... from /usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/commands/ server.rb:49 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in`gem\_original\_require’  
from /usr/local/lib/site\_ruby/1.8/rubygems/custom\_require.rb:31:in  
`require’  
from script/server:3

---

<div class="post-metadata">

**Author:** ![casper\_the\_ghost](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/c/58956e/32.png) [@casper\_the\_ghost](https://www.ruby-forum.com/u/casper_the_ghost)\
**Post date:** [December 17, 2008, 11:25am UTC](https://www.ruby-forum.com/t/upgrade-to-2-2-2-problem-with-existing-localization-library/155835/2 "2008-12-17T11:25:21Z")

</div>

yes there is. but it’s not (only) causing problems, but adding a  
translation feature. imho it’s actually nice to have.

check out railscasts to learn more about i18n:

> **[\#138 I18n - RailsCasts](http://railscasts.com/episodes/138-i18n)**
>
> Short Ruby on Rails screencasts containing tips, tricks and tutorials. Great for both novice and experienced web developers.

On 17 Dez., 10:56, “removed\_email\_address@domain.invalid”
