# Unable to upgrade rubygems

**URL:** <https://www.ruby-forum.com/t/unable-to-upgrade-rubygems/141297>\
**Category:** Ruby\
**Created:** [June 24, 2008, 1:45pm UTC](https://www.ruby-forum.com/t/unable-to-upgrade-rubygems/141297 "2008-06-24T13:45:27Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Une\_BSSSSvS\_ue](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/u/2acd7d/32.png) [@Une\_BSSSSvS\_ue](https://www.ruby-forum.com/u/Une_BSSSSvS_ue)\
**Post date:** [June 24, 2008, 1:45pm UTC](https://www.ruby-forum.com/t/unable-to-upgrade-rubygems/141297/1 "2008-06-24T13:45:27Z")

</div>

what i did :

download locally rubygems-update-1.2.0.gem

then :  
~/gems%\> sudo gem install -l rubygems-update-1.2.0.gem  
Password:  
Successfully installed rubygems-update-1.2.0  
1 gem installed

however i’ve still the 1.1 version :

~/gems%\> gem env  
RubyGems Environment:

- RUBYGEMS VERSION: 1.1.0 (1.1.0)
- RUBY VERSION: 1.8.6 (2007-09-24 patchlevel 111)  
[powerpc-darwin8.11.0]
- INSTALLATION DIRECTORY: /opt/local/lib/ruby/gems/1.8
- RUBY EXECUTABLE: /opt/local/bin/ruby
- RUBYGEMS PLATFORMS:
  - ruby
  - powerpc-darwin-8

- GEM PATHS:
  - /opt/local/lib/ruby/gems/1.8

- GEM CONFIGURATION:
  - :update\_sources =\> true
  - :verbose =\> true
  - :benchmark =\> false
  - :backtrace =\> false
  - :bulk\_threshold =\> 1000

- REMOTE SOURCES:
  - [http://gems.rubyforge.org](http://gems.rubyforge.org)

if i try installing using tar.gz :

~/src/ruby/rubygems-1.2.0%\> sudo ruby setup.rb  
Password:  
setup.rb:108: undefined method `ruby\_version’ for Gem:Module  
(NoMethodError)

by gem update :  
$ sudo gem update -r --system  
Updating RubyGems  
Updating metadata for 3 gems from [http://gems.rubyforge.org/](http://gems.rubyforge.org/)  
…  
complete  
Nothing to update

however :  
$ gem env  
RubyGems Environment:

- RUBYGEMS VERSION: 1.1.0 (1.1.0)
- RUBY VERSION: 1.8.6 (2007-09-24 patchlevel 111)  
[powerpc-darwin8.11.0]
- INSTALLATION DIRECTORY: /opt/local/lib/ruby/gems/1.8
- RUBY EXECUTABLE: /opt/local/bin/ruby
- RUBYGEMS PLATFORMS:
  - ruby
  - powerpc-darwin-8

- GEM PATHS:
  - /opt/local/lib/ruby/gems/1.8

- GEM CONFIGURATION:
  - :update\_sources =\> true
  - :verbose =\> true
  - :benchmark =\> false
  - :backtrace =\> false
  - :bulk\_threshold =\> 1000

- REMOTE SOURCES:
  - [http://gems.rubyforge.org](http://gems.rubyforge.org)

also, i wanted to install amalgalite and get :  
~/gems%\> sudo gem install -l amalgalite  
ERROR: Error installing amalgalite:  
amalgalite requires configuration (\>= 0.0.5)

however :  
$ sudo gem install -r configuration  
Password:  
Bulk updating Gem source index for: [http://gems.rubyforge.org/](http://gems.rubyforge.org/)  
ERROR: could not find configuration locally or in a repository

is my rubygems install broken ??

---

<div class="post-metadata">

**Author:** ![Une\_BSSSSvS\_ue](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/u/2acd7d/32.png) [@Une\_BSSSSvS\_ue](https://www.ruby-forum.com/u/Une_BSSSSvS_ue)\
**Post date:** [June 24, 2008, 2:11pm UTC](https://www.ruby-forum.com/t/unable-to-upgrade-rubygems/141297/2 "2008-06-24T14:11:55Z")

</div>

On Tue, Jun 24, 2008 at 7:43 AM, Une BÃ©vue  
[removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid) wrote:

> however i’ve still the 1.1 version :
> 
> ~/gems%\> gem env  
> RubyGems Environment:
> 
> - RUBYGEMS VERSION: 1.1.0 (1.1.0)

Installing the rubygems-update-1.2.0.gem just installs the upgrading  
tool,  
you still need to run it with

sudo update\_rubygems

THEN you should have 1.2 installed!

–  
Rick DeNatale

My blog on Ruby  
[http://talklikeaduck.denhaven2.com/](http://talklikeaduck.denhaven2.com/)

---

<div class="post-metadata">

**Author:** ![Une\_BSSSSvS\_ue](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/u/2acd7d/32.png) [@Une\_BSSSSvS\_ue](https://www.ruby-forum.com/u/Une_BSSSSvS_ue)\
**Post date:** [June 24, 2008, 2:25pm UTC](https://www.ruby-forum.com/t/unable-to-upgrade-rubygems/141297/3 "2008-06-24T14:25:25Z")

</div>

Rick DeNatale [removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid) wrote:

> Installing the rubygems-update-1.2.0.gem just installs the upgrading tool,  
> you still need to run it with
> 
> sudo update\_rubygems
> 
> THEN you should have 1.2 installed!

unfortunately i got :

$ sudo update\_rubygems  
Installing RubyGems 1.2.0  
setup.rb:108: undefined method `ruby\_version’ for Gem:Module  
(NoMethodError)

???

---

<div class="post-metadata">

**Author:** ![Une\_BSSSSvS\_ue](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/u/2acd7d/32.png) [@Une\_BSSSSvS\_ue](https://www.ruby-forum.com/u/Une_BSSSSvS_ue)\
**Post date:** [June 24, 2008, 2:50pm UTC](https://www.ruby-forum.com/t/unable-to-upgrade-rubygems/141297/4 "2008-06-24T14:50:38Z")

</div>

Rick DeNatale [removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid) wrote:

> On another thread you seemed to imply that you are still running Tiger  
> (10.4.11 IIRC) while I’m running Leopard (10.5.3) although I’d be surprised  
> if that were your problem.

anyway, thanks for your reply ))

---

<div class="post-metadata">

**Author:** ![Une\_BSSSSvS\_ue](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/u/2acd7d/32.png) [@Une\_BSSSSvS\_ue](https://www.ruby-forum.com/u/Une_BSSSSvS_ue)\
**Post date:** [June 24, 2008, 2:45pm UTC](https://www.ruby-forum.com/t/unable-to-upgrade-rubygems/141297/5 "2008-06-24T14:45:21Z")

</div>

On Tue, Jun 24, 2008 at 8:23 AM, Une BÃ©vue  
[removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid) wrote:

> > THEN you should have 1.2 installed!
> 
> unfortunately i got :
> 
> $ sudo update\_rubygems  
> Installing RubyGems 1.2.0  
> setup.rb:108: undefined method `ruby\_version’ for Gem:Module  
> (NoMethodError)
> 
> ???

Hmmmm, I don’t know what to say.

The local install of rubygems-update-1.2.0.gem and then running  
update\_rubygems is what finally worked for me.

On another thread you seemed to imply that you are still running Tiger  
(10.4.11 IIRC) while I’m running Leopard (10.5.3) although I’d be  
surprised  
if that were your problem.

–  
Rick DeNatale

My blog on Ruby  
[http://talklikeaduck.denhaven2.com/](http://talklikeaduck.denhaven2.com/)
