Spawner -p and --port not working?

Hi everyone,

I’m trying to set a port with spawner, and it’s not working:

ruby /var/rails/ldapadmin/current/script/process/spinner -c
/var/rails/ldapadmin/current/script/process/spawner --port=7000 -i 4
-d
spinner: invalid option: --port=7000

Same with -p:

ruby /var/rails/ldapadmin/current/script/process/spinner -c
/var/rails/ldapadmin/current/script/process/spawner -p 7000 -i 4 -d
spinner: invalid option: -p 7000

And then it just keeps spawning lots of fcgi processes that die
because the default port is already taken by another app on the
machine.

Why isn’t the port piece working?

Thanks,

Sean

Nevermind on this. Lighttpd wasn’t running. I still hadn’t separated
lighttpd and fcgi in my head. Lighty should be on, and SwitchTower
handles the fcgi processes, period. I think.

Sean

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs