Running lighttpd -> Recognition failed for "/"

i have tried several tutorials on the web for getting my app to run
under lighttpd and fastcgi…

my setup is fedora core 5…

i used this to get everything installed:

http://www.digitalmediaminute.com/howto/fc4rails/

but i kept getting errors, as the machine i am installing it is a remote
machine, i couldn’t get it to work right…

i next tried this:

http://www.bigbold.com/snippets/posts/show/175

and here are the errors i get…

when i try to hit the site, i get:

Routing Error

Recognition failed for “/”

when i look at the logs, i get:

Processing Base#index (for xx.xx.xx.xx at 2006-06-26 14:44:53) [GET]
Session ID: e09abedc28788dbbe1f6f8ac259a532e
Parameters: {}

ActionController::RoutingError (Recognition failed for “/”):
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_controller/routing.rb:488:in
recognition_failed' /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_controller/routing.rb:478:inrecognize!’
/usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/dispatcher.rb:38:in
dispatch' /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/fcgi_handler.rb:150:inprocess_request’
/usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/fcgi_handler.rb:54:in
process!' /usr/lib/ruby/site_ruby/1.8/fcgi.rb:600:ineach_cgi’
/usr/lib/ruby/site_ruby/1.8/fcgi.rb:117:in session' /usr/lib/ruby/site_ruby/1.8/fcgi.rb:104:ineach_request’
/usr/lib/ruby/site_ruby/1.8/fcgi.rb:36:in each' /usr/lib/ruby/site_ruby/1.8/fcgi.rb:597:ineach_cgi’
/usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/fcgi_handler.rb:53:in
process!' /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/fcgi_handler.rb:23:inprocess!’
/home/sergio/test/public/dispatch.fcgi:24

and this:

[26/Jun/2006:14:43:41 :: 8541] Dispatcher failed to catch: (Interrupt)
/usr/lib/ruby/site_ruby/1.8/fcgi.rb:113:in accept' /usr/lib/ruby/site_ruby/1.8/fcgi.rb:113:insession’
/usr/lib/ruby/site_ruby/1.8/fcgi.rb:104:in each_request' /usr/lib/ruby/site_ruby/1.8/fcgi.rb:36:ineach’
/usr/lib/ruby/site_ruby/1.8/fcgi.rb:597:in each_cgi' /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/fcgi_handler.rb:53:inprocess!’
/usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/fcgi_handler.rb:23:in
`process!’
/home/sergio/test/public/dispatch.fcgi:24
killed by this error

my lighttpd.conf looks like this:

server.port = 80
server.bind = “0.0.0.0”

server.pid-file = “/tmp/test_lighttpd.pid”
#server.event-handler = “freebsd-kqueue”

server.modules = ( “mod_rewrite”, “mod_redirect”, “mod_access”,
“mod_fastcgi”, “mod_accesslog” )

server.document-root = “/home/sergio/test/public/”
server.indexfiles = ( “dispatch.fcgi”, “index.html” )
accesslog.filename =
“/home/sergio/test/log/lighttpd_access.log”
server.errorlog = “/home/sergio/test/log/lighttpd_error.log”
server.error-handler-404 = “/dispatch.fcgi”

fastcgi module

read fastcgi.txt for more info

fastcgi.server = (
“.fcgi” => (
“test” => (
“socket” => “/tmp/test1.socket”,
“bin-path” => “/home/sergio/test/public/dispatch.fcgi”,
“min-procs” => 1,
“max_procs” => 2
)
)
)

i am sure i forgot to include something that would be really helpful…
but i hope this is enough for now…

thanks!

i have tried several tutorials on the web for getting my app to run
under lighttpd and fastcgi…

Recognition failed for “/”

its very particular about trailing slashes in lighttpd.conf. if they are
there, try removing them (or vice versa) in the 3 or so places where
they are defined (depending on if you are using an abstract root or
not).

make sure you have a route hooked up for ‘’ in routes.rb

if that fails, check for a more useful error in /var/log/lighttpd/*,
YOURAPP/logs/fastcgi.crash.log YOURAPP/log/{development,production}.log.
sometimes a version mismatch or missing gem or such will leave a totally
nondescript error in the browser, if any…

if that fails, try mongrel…

good luck!

if that fails, try mongrel…

i will try these things for sure…

i will probably write another post about this, but i am not sure what
mongrel is… i have read a little about it… i will check it out…

thanks!

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs