# RubyGems nightmare due to 2 installs

**URL:** <https://www.ruby-forum.com/t/rubygems-nightmare-due-to-2-installs/179623>\
**Category:** Ruby\
**Created:** [November 30, 2009, 7:06pm UTC](https://www.ruby-forum.com/t/rubygems-nightmare-due-to-2-installs/179623 "2009-11-30T19:06:24Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![hirodusk](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/h/6f9a4e/32.png) [@hirodusk](https://www.ruby-forum.com/u/hirodusk)\
**Post date:** [November 30, 2009, 7:06pm UTC](https://www.ruby-forum.com/t/rubygems-nightmare-due-to-2-installs/179623/1 "2009-11-30T19:06:24Z")

</div>

I have a recurring problem with my RubyGems install atm… actually  
there are 2 of them, one in /usr/local/lib and the other in /usr/lib

I think it ended up that way after upgrading ruby to 1.8.6.

I have somehow managed to get around problems, but each time I start a  
new Rails project, on the server it gives me this error (usuallly on  
rake):

Rails requires RubyGems \>= 1.3.1 (you have 1.3.0). Please `gem update --system` and try again.

Everytime I try and install it installs in /usr/local/ … which is  
obviously not where Rails is looking.  
I have tried a few things, searched here and googled, but nothing I try  
seems to work so far…

Any tips much appreciated, need to squash this problem once and for all,  
without risking currently running rails sites.

Many thanks
