# Rubygems 1.3.5 thinks it's 1.3.1

**URL:** <https://www.ruby-forum.com/t/rubygems-1-3-5-thinks-its-1-3-1/175793>\
**Category:** Rails\
**Created:** [September 19, 2009, 9:43pm UTC](https://www.ruby-forum.com/t/rubygems-1-3-5-thinks-its-1-3-1/175793 "2009-09-19T21:43:05Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Arthaey\_Angosii](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/a/f17d59/32.png) [@Arthaey\_Angosii](https://www.ruby-forum.com/u/Arthaey_Angosii)\
**Post date:** [September 19, 2009, 9:43pm UTC](https://www.ruby-forum.com/t/rubygems-1-3-5-thinks-its-1-3-1/175793/1 "2009-09-19T21:43:05Z")

</div>

I upgraded to Rails to 2.3.4, and now some things aren’t working in a  
freshly created Rails project. For example:

$ script/plugin -l  
Rails requires RubyGems \>= 1.3.2 (you have 1.3.1). Please `gem update --system` and try again.

So I’m trying to update rubygems (in a user directory; I don’t have  
sudo access). But the gem binary I download from RubyForge thinks that  
it’s version 1.3.1:

$ wget [http://rubyforge.org/frs/download.php/60718/rubygems-1.3.5.tgz](http://rubyforge.org/frs/download.php/60718/rubygems-1.3.5.tgz)  
$ tar vxzf rubygems-1.3.5.tgz  
$ cd rubygems-1.3.5/  
$ ./bin/gem --version  
1.3.1

Has anyone seen this before?

---

<div class="post-metadata">

**Author:** ![Arthaey\_Angosii](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/a/f17d59/32.png) [@Arthaey\_Angosii](https://www.ruby-forum.com/u/Arthaey_Angosii)\
**Post date:** [September 19, 2009, 11:36pm UTC](https://www.ruby-forum.com/t/rubygems-1-3-5-thinks-its-1-3-1/175793/2 "2009-09-19T23:36:40Z")

</div>

That is because you have more than one Ruby installation and when you  
installed your RubyGems 1.3.5 it was not installed in the global Ruby  
install and rather your local install.

Try running a few which gem and which ruby commands to hunt down the  
issue. You might also have to look at your path to figure this out.

Just as an example on one of my servers I have the normal /usr/local/  
bin/ruby install but I also have /opt/ruby-enterprise/bin/ruby which  
is what I use and I have to make sure this is in the front of my path  
or else I might install a gem under the wrong directory…

This does the trick:  
export PATH=/opt/ruby-enterprise/bin:$PATH

---

<div class="post-metadata">

**Author:** ![Arthaey\_Angosii](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/a/f17d59/32.png) [@Arthaey\_Angosii](https://www.ruby-forum.com/u/Arthaey_Angosii)\
**Post date:** [September 21, 2009, 10:33am UTC](https://www.ruby-forum.com/t/rubygems-1-3-5-thinks-its-1-3-1/175793/3 "2009-09-21T10:33:15Z")

</div>

Hi Guys

I also faced the same problem but i fixed the issue by the following  
steps:

Go to the below directory and you can find “update\_rubygems” file which  
needs to be executed then it will update the gem version 1.3.5.

cd ~/.gem/ruby/1.8/bin/  
./update\_rubygems

If gem is updated then you have to install rails too since its new  
version and it removes the old version local repositary.

Please guide us if i am doing the wrong way…

Thanks  
Gopi

heimdull wrote:

> That is because you have more than one Ruby installation and when you  
> installed your RubyGems 1.3.5 it was not installed in the global Ruby  
> install and rather your local install.
> 
> Try running a few which gem and which ruby commands to hunt down the  
> issue. You might also have to look at your path to figure this out.
> 
> Just as an example on one of my servers I have the normal /usr/local/  
> bin/ruby install but I also have /opt/ruby-enterprise/bin/ruby which  
> is what I use and I have to make sure this is in the front of my path  
> or else I might install a gem under the wrong directory…
> 
> This does the trick:  
> export PATH=/opt/ruby-enterprise/bin:$PATH

---

<div class="post-metadata">

**Author:** ![Arthaey\_Angosii](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/a/f17d59/32.png) [@Arthaey\_Angosii](https://www.ruby-forum.com/u/Arthaey_Angosii)\
**Post date:** [September 21, 2009, 10:37am UTC](https://www.ruby-forum.com/t/rubygems-1-3-5-thinks-its-1-3-1/175793/4 "2009-09-21T10:37:20Z")

</div>

Hi Guys

I also faced the same problem but i fixed the issue by the following  
steps:

Go to the below directory and you can find “update\_rubygems” file which  
needs to be executed then it will update the gem version 1.3.5.

cd ~/.gem/ruby/1.8/bin/  
./update\_rubygems

If gem is updated then you have to install rails too since its new  
version and it removes the old version local repositary.

Thanks  
Gopi

Arthaey Angosii wrote:

> I upgraded to Rails to 2.3.4, and now some things aren’t working in a  
> freshly created Rails project. For example:
> 
> $ script/plugin -l  
> Rails requires RubyGems \>= 1.3.2 (you have 1.3.1). Please `gem update --system` and try again.
> 
> So I’m trying to update rubygems (in a user directory; I don’t have  
> sudo access). But the gem binary I download from RubyForge thinks that  
> it’s version 1.3.1:
> 
> $ wget [http://rubyforge.org/frs/download.php/60718/rubygems-1.3.5.tgz](http://rubyforge.org/frs/download.php/60718/rubygems-1.3.5.tgz)  
> $ tar vxzf rubygems-1.3.5.tgz  
> $ cd rubygems-1.3.5/  
> $ ./bin/gem --version  
> 1.3.1
> 
> Has anyone seen this before?
