# Ruby update on OS X 10.5 and I now this: "Rails requires RubyGems \>= 1.3.2"

**URL:** <https://www.ruby-forum.com/t/ruby-update-on-os-x-10-5-and-i-now-this-rails-requires-rubygems-1-3-2/183607>\
**Category:** Rails\
**Created:** [February 17, 2010, 9:45am UTC](https://www.ruby-forum.com/t/ruby-update-on-os-x-10-5-and-i-now-this-rails-requires-rubygems-1-3-2/183607 "2010-02-17T09:45:44Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![Grary](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/g/91b2a8/32.png) [@Grary](https://www.ruby-forum.com/u/Grary)\
**Post date:** [February 17, 2010, 9:45am UTC](https://www.ruby-forum.com/t/ruby-update-on-os-x-10-5-and-i-now-this-rails-requires-rubygems-1-3-2/183607/1 "2010-02-17T09:45:44Z")

</div>

Hi all,

I’ve seen other messages on this problem, but I still can’t get back  
to working with Rails after using MacPorts to install a recent version  
of ruby on my mac OS X 10.5 (ruby 1.8.7.)

I’m getting: “Rails requires RubyGems \>= 1.3.2.”

In fact, I am running rubygems 1.3.5.

Here are some settings of mine that seemed important in previous posts  
on this issue:

which ruby…  
/opt/local/bin/ruby

which gem…  
/usr/bin/gem

My path variable seems consistent with the “which ruby” result above.

Do I need to change the path – or any other – settings in RubyGems?

Thanks for any help,

Grary

---

<div class="post-metadata">

**Author:** ![Grary](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/g/91b2a8/32.png) [@Grary](https://www.ruby-forum.com/u/Grary)\
**Post date:** [February 17, 2010, 10:50am UTC](https://www.ruby-forum.com/t/ruby-update-on-os-x-10-5-and-i-now-this-rails-requires-rubygems-1-3-2/183607/2 "2010-02-17T10:50:08Z")

</div>

On Feb 17, 3:05 am, Grary [removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid) wrote:

> Here are some settings of mine that seemed important in previous posts  
> on this issue:
> 
> which ruby…  
> /opt/local/bin/ruby
> 
> which gem…  
> /usr/bin/gem

You have two installs of ruby, one in /opt/local, one in /usr/bin and  
the two have different versions of rubygems - if your PATH has /opt/  
local/bin higher up then the /opt/local install of ruby might not have  
rubygems at all. Sounds like you need to install rubygems for your new  
ruby install

Fred

---

<div class="post-metadata">

**Author:** ![Grary](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/g/91b2a8/32.png) [@Grary](https://www.ruby-forum.com/u/Grary)\
**Post date:** [February 17, 2010, 1:22pm UTC](https://www.ruby-forum.com/t/ruby-update-on-os-x-10-5-and-i-now-this-rails-requires-rubygems-1-3-2/183607/3 "2010-02-17T13:22:56Z")

</div>

Fred,

Per your comment…

“…if your PATH has /opt/local/bin higher up then the /opt/local  
install of ruby might not have  
rubygems at all. Sounds like you need to install rubygems for your new  
ruby install”

…yes, here is my path:

/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/  
local/bin:/usr/X11/bin:/opt/local/bin/ruby

So, you’re recommending that I install RubyGems anew? Can’t I modify  
the recognition of my new ruby installation for RubyGems?

Thanks,

Grar

---

<div class="post-metadata">

**Author:** ![Grary](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/g/91b2a8/32.png) [@Grary](https://www.ruby-forum.com/u/Grary)\
**Post date:** [February 17, 2010, 3:00pm UTC](https://www.ruby-forum.com/t/ruby-update-on-os-x-10-5-and-i-now-this-rails-requires-rubygems-1-3-2/183607/4 "2010-02-17T15:00:42Z")

</div>

Fred,

I’m just hoping to get Rails working again, so I’ll do whatever’s  
easy…

sudo gem install rubygems-update  
sudo update\_rubygems

…I still get the same message.

What did you mean when you wrote: “Sounds like you need to install  
rubygems for your new  
ruby install”?

Thanks,

Grar

---

<div class="post-metadata">

**Author:** ![Grary](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/g/91b2a8/32.png) [@Grary](https://www.ruby-forum.com/u/Grary)\
**Post date:** [February 17, 2010, 4:50pm UTC](https://www.ruby-forum.com/t/ruby-update-on-os-x-10-5-and-i-now-this-rails-requires-rubygems-1-3-2/183607/5 "2010-02-17T16:50:14Z")

</div>

On Feb 17, 1:59 pm, Grary [removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid) wrote:

> Fred,
> 
> I’m just hoping to get Rails working again, so I’ll do whatever’s  
> easy…
> 
> sudo gem install rubygems-update  
> sudo update\_rubygems
> 
> …I still get the same message.

That’s because you’re installing rubygems-update using gem which is  
usr/bin/gem (ie the previous ruby install).  
You need a fresh install of rubygems - grab it off the rubygems  
download page ([http://rubyforge.org/projects/rubygems/](http://rubyforge.org/projects/rubygems/) - you want zip  
file or the tarball)

Fred

---

<div class="post-metadata">

**Author:** ![Grary](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/g/91b2a8/32.png) [@Grary](https://www.ruby-forum.com/u/Grary)\
**Post date:** [February 17, 2010, 5:04pm UTC](https://www.ruby-forum.com/t/ruby-update-on-os-x-10-5-and-i-now-this-rails-requires-rubygems-1-3-2/183607/6 "2010-02-17T17:04:17Z")

</div>

Fred,

Thanks. I reinstalled the whole thing such that

which ruby  
/opt/local/bin/ruby

which gem  
/opt/local/bin/gem

Rails now seems to respond as desired.

Doubtless I’ll need to better familiarize myself with the interaction  
of ruby and rubygems for further growth in Rails.

best,

Grar

On Feb 17, 10:48 am, Frederick C. [removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid)

---

<div class="post-metadata">

**Author:** ![Grary](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/g/91b2a8/32.png) [@Grary](https://www.ruby-forum.com/u/Grary)\
**Post date:** [February 17, 2010, 1:51pm UTC](https://www.ruby-forum.com/t/ruby-update-on-os-x-10-5-and-i-now-this-rails-requires-rubygems-1-3-2/183607/7 "2010-02-17T13:51:38Z")

</div>

On Feb 17, 12:21 pm, Grary [removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid) wrote:

> So, you’re recommending that I install RubyGems anew? Can’t I modify  
> the recognition of my new ruby installation for RubyGems?

Well you could try transplanting the various bits of rubygems from  
one ruby install to another but even if you knew exactly what to move  
around that might not work (eg gems with native extensions compiled  
against different version of ruby).

Fred

---

<div class="post-metadata">

**Author:** ![Grary](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/g/91b2a8/32.png) [@Grary](https://www.ruby-forum.com/u/Grary)\
**Post date:** [February 17, 2010, 5:27pm UTC](https://www.ruby-forum.com/t/ruby-update-on-os-x-10-5-and-i-now-this-rails-requires-rubygems-1-3-2/183607/8 "2010-02-17T17:27:08Z")

</div>

On Wed, Feb 17, 2010 at 8:03 AM, Grary [removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid) wrote:

> Thanks. I reinstalled the whole thing such that
> 
> which ruby  
> /opt/local/bin/ruby  
> which gem  
> /opt/local/bin/gem

> Doubtless I’ll need to better familiarize myself with the interaction  
> of ruby and rubygems for further growth in Rails.

Just to be clear – this has NOTHING to do with ruby, gems, or rails  
specifically. This is learning basic \*nix – how the PATH environment  
variable determines what executables are found.

You would face the same issue with multiple installations of any other  
languages or apps.

## FWIW,

Hassan S. ------------------------ removed\_email\_address@domain.invalid  
twitter: @hassan
