Routing Error after upgrade


#1

My hosting company has upgraded to: ruby-1.8.5 rubygems-0.9.0

And I am now getting the following error on my ruby site:

no route found to match ”/en/public/” with {:method=>:get}
/usr/local/lib/ruby/gems/1.8/gems/actionpack-1.13.2/lib/action_controller/routing.rb:1292:in
recognize_path’ /usr/local/lib/ruby/gems/1.8/gems/actionpack-1.13.2/lib/action_controller/routing.rb:1282:inrecognize’
/usr/local/lib/ruby/gems/1.8/gems/rails-1.2.2/lib/dispatcher.rb:40:in
dispatch’ /usr/local/lib/ruby/gems/1.8/gems/rails-1.2.2/lib/fcgi_handler.rb:168:inprocess_request’
/usr/local/lib/ruby/gems/1.8/gems/rails-1.2.2/lib/fcgi_handler.rb:143:in
process_each_request!’ /usr/local/lib/ruby/gems/1.8/gems/rails-1.2.2/lib/fcgi_handler.rb:109:inwith_signal_handler’
/usr/local/lib/ruby/gems/1.8/gems/rails-1.2.2/lib/fcgi_handler.rb:142:in
process_each_request!’ /usr/local/lib/ruby/gems/1.8/gems/fcgi-0.8.7/lib/fcgi.rb:612:ineach_cgi’
/usr/local/lib/ruby/gems/1.8/gems/fcgi-0.8.7/lib/fcgi.rb:609:in each’ /usr/local/lib/ruby/gems/1.8/gems/fcgi-0.8.7/lib/fcgi.rb:609:ineach_cgi’
/usr/local/lib/ruby/gems/1.8/gems/rails-1.2.2/lib/fcgi_handler.rb:141:in
process_each_request!’ /usr/local/lib/ruby/gems/1.8/gems/rails-1.2.2/lib/fcgi_handler.rb:55:inprocess!’
/usr/local/lib/ruby/gems/1.8/gems/rails-1.2.2/lib/fcgi_handler.rb:25:in
`process!’ /home/scotarch/public_html/en/public/dispatch.fcgi:24

They are telling me everything is working fine on the server and can’t
help me.

In my routes.rb I set up the following routing: map.connect ’’,
:controller => “page”, :action => ‘view’, :id => ‘home.html’

I have checked my controllers and there is a page_controller.rb setup
with a view function defined.

I tried setting my rails root in the file /en/public/.htaccess but that
has made no differance.

Can any one tell me why I may be getting this error?

Thank you :slight_smile: