# Revert back to rubygems 0.9 from 1.0.1

**URL:** <https://www.ruby-forum.com/t/revert-back-to-rubygems-0-9-from-1-0-1/134191>\
**Category:** Ruby\
**Created:** [April 8, 2008, 6:42pm UTC](https://www.ruby-forum.com/t/revert-back-to-rubygems-0-9-from-1-0-1/134191 "2008-04-08T18:42:05Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![dkmd\_nielsen](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/d/958977/32.png) [@dkmd\_nielsen](https://www.ruby-forum.com/u/dkmd_nielsen)\
**Post date:** [April 8, 2008, 6:42pm UTC](https://www.ruby-forum.com/t/revert-back-to-rubygems-0-9-from-1-0-1/134191/1 "2008-04-08T18:42:05Z")

</div>

My debugger is having a problem with rubygems v1.0.1. I would like to  
revert back to rubygems 0.9, if that is possible. What steps are  
necessary to back out v1.0.1 and re-install 0.9.x?

Thanks for your time,  
dvn

---

<div class="post-metadata">

**Author:** ![dkmd\_nielsen](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/d/958977/32.png) [@dkmd\_nielsen](https://www.ruby-forum.com/u/dkmd_nielsen)\
**Post date:** [April 8, 2008, 8:10pm UTC](https://www.ruby-forum.com/t/revert-back-to-rubygems-0-9-from-1-0-1/134191/2 "2008-04-08T20:10:58Z")

</div>

On Apr 8, 1:35 pm, dkmd\_nielsen [removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid) wrote:

> My debugger is having a problem with rubygems v1.0.1. I would like to  
> revert back to rubygems 0.9, if that is possible. What steps are  
> necessary to back out v1.0.1 and re-install 0.9.x?

gem update --system -v ‘0.9.x’

HTH,

---

<div class="post-metadata">

**Author:** ![dkmd\_nielsen](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/d/958977/32.png) [@dkmd\_nielsen](https://www.ruby-forum.com/u/dkmd_nielsen)\
**Post date:** [April 8, 2008, 8:31pm UTC](https://www.ruby-forum.com/t/revert-back-to-rubygems-0-9-from-1-0-1/134191/3 "2008-04-08T20:31:01Z")

</div>

On Apr 8, 1:09 pm, Luis L. [removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid) wrote:

> Luis L.  
> Thanks. Unfortunately, that’s not it. I don’t see a specific version  
> provision with update.

E:\Scripts\Testing\>gem update --system -v ‘0.9.0’  
Updating RubyGems…  
ERROR: While executing gem … (RuntimeError)  
No gem names are allowed with the --system option

E:\Scripts\Testing\>

---

<div class="post-metadata">

**Author:** ![dkmd\_nielsen](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/d/958977/32.png) [@dkmd\_nielsen](https://www.ruby-forum.com/u/dkmd_nielsen)\
**Post date:** [April 9, 2008, 5:26pm UTC](https://www.ruby-forum.com/t/revert-back-to-rubygems-0-9-from-1-0-1/134191/4 "2008-04-09T17:26:08Z")

</div>

On Apr 8, 2:07 pm, Luis L. [removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid) wrote:

> > > > necessary to back out v1.0.1 and re-install 0.9.x?  
> > > > E:\Scripts\Testing\>gem update --system -v ‘0.9.0’  
> > > > [http://rubyforge.org/frs/shownotes.php?release\_id=5803](http://rubyforge.org/frs/shownotes.php?release_id=5803)  
> > > > Regards,  
> > > > –  
> > > > Luis L.

The IDE debugger I am using is ArachnoRuby. I switched my development  
environment, where the new one has rubygems 1.0.1. However, in  
processing the gem and require statements, I would get this weird  
error about not being able to convert nil to integer. The exact same  
script would work with SCITE and from the command line. I contacted  
the author of ArachnoRuby and said it was odd. He said it made sense  
to him and there is something he needs to fix.

I will update all my servers to rubygems 0.9.4. I wasn’t sure which  
version is the correct one. All my servers are using 0.9.0; and they  
are all fine.

Anything more you need? Just let me know.

Thanks a bunch,  
dvn

---

<div class="post-metadata">

**Author:** ![dkmd\_nielsen](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/d/958977/32.png) [@dkmd\_nielsen](https://www.ruby-forum.com/u/dkmd_nielsen)\
**Post date:** [April 8, 2008, 9:11pm UTC](https://www.ruby-forum.com/t/revert-back-to-rubygems-0-9-from-1-0-1/134191/5 "2008-04-08T21:11:29Z")

</div>

On Apr 8, 3:25 pm, dkmd\_nielsen [removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid) wrote:

> > HTH,
> 
> E:\Scripts\Testing\>

Sorry, my bad. The cleanest method will involve:

Download rubygems-0.9.0.zip package from rubyforge:

[http://rubyforge.org/frs/shownotes.php?release\_id=5803](http://rubyforge.org/frs/shownotes.php?release_id=5803)

Unzip and run ‘ruby setup.rb install’

Just curious: why you want to revert to 0.9.0? instead of 0.9.4 which  
was more stable.

Also, can you provide more information about the trouble you’re  
having, so we can track if the problem is in RubyGems or the  
“debugger” gem you mention.

Regards,

---

<div class="post-metadata">

**Author:** ![dkmd\_nielsen](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/d/958977/32.png) [@dkmd\_nielsen](https://www.ruby-forum.com/u/dkmd_nielsen)\
**Post date:** [April 11, 2008, 12:03am UTC](https://www.ruby-forum.com/t/revert-back-to-rubygems-0-9-from-1-0-1/134191/6 "2008-04-11T00:03:44Z")

</div>

On Apr 9, 2008, at 08:25 AM, dkmd\_nielsen wrote:

> I will update all my servers to rubygems 0.9.4. I wasn’t sure which  
> version is the correct one. All my servers are using 0.9.0; and they  
> are all fine.

0.9.0 and earlier have an installation exploit that allow gems to  
install files into arbitrary locations on the filesystem. Use at  
least 0.9.1.
