RE: Re: WebServices and DateTime - 3 elements of civil date


#1

Are you using Windows? I ran into the same problem. There
is a problem
with Ruby and the Windows DateTime format. I still haven’t found a
solution to this. Supposedly ruby 1.9 fixes this, but after
replacing
the 1.8 date files with the 1.9 ones it still doesn’t work for me.

The date/format.rb that ships with the stdlib doesn’t support long
timezone names. You have two options. One is to hand edit the
format.rb file directly and add the long timezone names to the
Format::ZONES constant. The other is to change the timezone format in
the Windows registry.

HKEY_LOCAL_MACHINE/System/CurrentControlSet/Control/TimeZoneInformation
is the key you want.

Editing the registry requires a reboot to take effect afaik.

Regards,

Dan

This communication is the property of Qwest and may contain confidential
or
privileged information. Unauthorized use of this communication is
strictly
prohibited and may be unlawful. If you have received this communication
in error, please immediately notify the sender by reply e-mail and
destroy
all copies of the communication and any attachments.