Re: New free IBM DB2 with few restrictions


#1

Can anyone comment as to the status of Rails support for DB2?
ActiveRecord has complete DB2 support and there are people using it
on Linux, AIX, and Win32 (it uses the ruby-db2 library:
http://rubyforge.org/frs/download.php/8264/ruby-db2-0.4.4.tar.gz).

Most of the Rails stuff works with DB2, too. There have been some
problems with scaffolding in former versions, but they have been
solved in the current svn revision. Unfortunately, the Rails
framework makes some assumptions about the support of quoted integers
at some points. So be prepared to insert a to_i or to_s here and
thereā€¦

Cheers

Maik