RangeError problem


#1

Hi,

My Ruby On Rails installation used to work on my Mac OSX. I recently
upgraded my Mac to 10.4.6. Since then my RoR installation doesn’t seem
to work.

When I try to access pages that use gettext I get the following error

RangeError in AdminController#list

bignum too big to convert into `long’

RAILS_ROOT: script/…/config/…
Application Trace | Framework Trace | Full Trace

/usr/lib/ruby/gems/1.8/gems/gettext-1.4.0/lib/gettext/mo.rb:66:in read' /usr/lib/ruby/gems/1.8/gems/gettext-1.4.0/lib/gettext/mo.rb:66:inload_from_stream’

I’m on rails 1.1.2 and gettext 1.4.0 and my Ruby version is

ruby 1.8.2 (2004-12-25) [powerpc-darwin8.0]

Does anyone have an idea ?

kr

Torben Bruun