Randomly keys translation missing in production

Hello everyone
i use
rails (= 3.0.3)
i18n (0.5.0)

in development all fine
in production i get translation missing
i found temp solution to change

config.cache_classes = false

in production but i wouldn’t like turn off caching…

my locale is :ru

ls -l config/locales/
итого 24
-rw-rw-r-- 1 dnevnik dnevnik 1850 Янв 15 00:18 devise.en.yml
-rw-rw-r-- 1 dnevnik dnevnik 2717 Янв 15 00:18 devise.ru.yml
-rw-rw-r-- 1 dnevnik dnevnik 305 Янв 15 00:18 en.yml
-rw-rw-r-- 1 dnevnik dnevnik 678 Янв 15 00:18 netzke.ru.yml
-rw-rw-r-- 1 dnevnik dnevnik 6529 Янв 15 00:18 ru.yml

grep i18n config/application.rb

config.i18n.load_path += Dir[Rails.root.join('my', 'locales', '*.

{rb,yml}’).to_s]
config.i18n.default_locale = :ru

Any suggestions?

Exactly the same thing is happening with me. Turning off cache also
clears
the problem.

I tried clearing the cache using Rails.cache.clear withing a
initializer,
but did’t produce any results.

Still no clue on what’s causing it.

Any ideas?

cheers

Diogo

Looks like this guy got to the bottom of it.

His solution worked for me, altought I did make a small change on the
load
path, to include all my locales, just in case.

http://stackoverflow.com/questions/4884970/mixed-locales-in-rails-i18n

Cheers

Diogo

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs