# Rake 0.8.7 needs Ruby 1.8?

**URL:** <https://www.ruby-forum.com/t/rake-0-8-7-needs-ruby-1-8/186138>\
**Category:** Ruby\
**Created:** [April 1, 2010, 2:03am UTC](https://www.ruby-forum.com/t/rake-0-8-7-needs-ruby-1-8/186138 "2010-04-01T02:03:31Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![jasv](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/j/b19c9b/32.png) [@jasv](https://www.ruby-forum.com/u/jasv)\
**Post date:** [April 1, 2010, 2:03am UTC](https://www.ruby-forum.com/t/rake-0-8-7-needs-ruby-1-8/186138/1 "2010-04-01T02:03:31Z")

</div>

Hello…

I am trying to install a Ruby application called Redmine. In order to  
create database structure, I have to execute this command: rake  
db:migrate

When I run it, a message telling that msvcrt-ruby18.dll was not found  
(I’m attaching the complete message). I have downloaded the last ruby  
version (1.9.1) and when I install it, it automatically installed rake  
0.8.7. Since I have msvcrt-ruby191.dll, why rake is trying to load the  
wrong DLL?

This is the environment setting:

RubyGems Environment:

- RUBYGEMS VERSION: 1.3.6
- RUBY VERSION: 1.9.1 (2010-01-10 patchlevel 378) [i386-mingw32]
- INSTALLATION DIRECTORY: C:/Ruby19/lib/ruby/gems/1.9.1
- RUBY EXECUTABLE: C:/Ruby19/bin/ruby.exe
- EXECUTABLE DIRECTORY: C:/Ruby19/bin
- RUBYGEMS PLATFORMS:
  - ruby
  - x86-mingw32

- GEM PATHS:
  - C:/Ruby19/lib/ruby/gems/1.9.1
  - C:/Documents and Settings/Administrator/.gem/ruby/1.9.1

- GEM CONFIGURATION:
  - :update\_sources =\> true
  - :verbose =\> true
  - :benchmark =\> false
  - :backtrace =\> false
  - :bulk\_threshold =\> 1000

- REMOTE SOURCES:
  - [http://rubygems.org/](http://rubygems.org/)

And these are the gems that were installed automatically:

\*\*\* LOCAL GEMS \*\*\*

actionmailer (2.3.5)  
actionpack (2.3.5)  
activerecord (2.3.5)  
activeresource (2.3.5)  
activesupport (2.3.5)  
mysql (2.8.1)  
rack (1.0.1)  
rails (2.3.5)  
rake (0.8.7)  
rmagick (2.12.0)  
rubygems-update (1.3.6)

Any help will be greatly appreciated  
Thanks

Jaime

---

<div class="post-metadata">

**Author:** ![jasv](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/j/b19c9b/32.png) [@jasv](https://www.ruby-forum.com/u/jasv)\
**Post date:** [April 1, 2010, 7:37am UTC](https://www.ruby-forum.com/t/rake-0-8-7-needs-ruby-1-8/186138/2 "2010-04-01T07:37:48Z")

</div>

Jaime S. wrote:

> Hello…
> 
> I am trying to install a Ruby application called Redmine. In order to  
> create database structure, I have to execute this command: rake  
> db:migrate
> 
> When I run it, a message telling that msvcrt-ruby18.dll was not found  
> (I’m attaching the complete message). I have downloaded the last ruby  
> version (1.9.1) and when I install it, it automatically installed rake  
> 0.8.7. Since I have msvcrt-ruby191.dll, why rake is trying to load the  
> wrong DLL?

This means “you’re running some gem or other that has binaries for 1.8  
but not 1.9” what’s your backtrace? (rake --trace I think).  
-rp

---

<div class="post-metadata">

**Author:** ![jasv](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/j/b19c9b/32.png) [@jasv](https://www.ruby-forum.com/u/jasv)\
**Post date:** [April 1, 2010, 11:54am UTC](https://www.ruby-forum.com/t/rake-0-8-7-needs-ruby-1-8/186138/3 "2010-04-01T11:54:27Z")

</div>

Hello Roger… by executing that command, I receive this response:

C:\Documents and Settings\Administrator\>rake --trace  
rake aborted!  
No Rakefile found (looking for: rakefile, Rakefile, rakefile.rb,  
Rakefile.rb)  
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:2377:in  
`raw_load_rake file' C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:2017:in`block  
in load  
\_rakefile’  
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:2068:in  
`standard_exce ption_handling' C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:2016:in`load\_rakefile  
’  
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:2000:in `block  
in run’

C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:2068:in  
`standard_exce ption_handling' C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:1998:in`run’  
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-0.8.7/bin/rake:31:in `<top (required)>' C:/Ruby19/bin/rake:19:in`load’  
C:/Ruby19/bin/rake:19:in `’

Thanks  
Jaime

Roger P. wrote:

> Jaime S. wrote:
> 
> > Hello…
> > 
> > I am trying to install a Ruby application called Redmine. In order to  
> > create database structure, I have to execute this command: rake  
> > db:migrate
> > 
> > When I run it, a message telling that msvcrt-ruby18.dll was not found  
> > (I’m attaching the complete message). I have downloaded the last ruby  
> > version (1.9.1) and when I install it, it automatically installed rake  
> > 0.8.7. Since I have msvcrt-ruby191.dll, why rake is trying to load the  
> > wrong DLL?
> 
> This means “you’re running some gem or other that has binaries for 1.8  
> but not 1.9” what’s your backtrace? (rake --trace I think).  
> -rp

---

<div class="post-metadata">

**Author:** ![jasv](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/j/b19c9b/32.png) [@jasv](https://www.ruby-forum.com/u/jasv)\
**Post date:** [April 1, 2010, 7:13pm UTC](https://www.ruby-forum.com/t/rake-0-8-7-needs-ruby-1-8/186138/4 "2010-04-01T19:13:48Z")

</div>

> Hello Roger… by executing that command, I receive this response:
> 
> C:\Documents and Settings\Administrator\>rake --trace  
> rake aborted!

Thanks for doing that. The backtrace I even more desire would be  
$ rake db:migrate --trace

My first guess is a bad mysql gem [?] but the backtrace will tell us  
better.  
-rp

---

<div class="post-metadata">

**Author:** ![jasv](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/j/b19c9b/32.png) [@jasv](https://www.ruby-forum.com/u/jasv)\
**Post date:** [April 2, 2010, 2:25am UTC](https://www.ruby-forum.com/t/rake-0-8-7-needs-ruby-1-8/186138/5 "2010-04-02T02:25:35Z")

</div>

On Apr 1, 2:03 am, Jaime S. [removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid) wrote:

> wrong DLL?

Rake do not depend directly of Ruby runtime library either for 1.8 or  
1.9, as is pure ruby.

What you might be experiencing is a gem that your application depends  
on that do not provide binaries for Ruby 1.9, the version fo Ruby  
you’re running.

Please provide the output of “rake db:migrate --trace” from inside  
your application folder and not your home/profile directory as you  
executed in response to Roger comments.

> ```
> - x86-mingw32
> -http://rubygems.org/
> 
> ```
> 
> mysql (2.8.1)  
> rack (1.0.1)  
> rails (2.3.5)  
> rake (0.8.7)  
> rmagick (2.12.0)  
> rubygems-update (1.3.6)

My guess will be around rmagick gem, as I’m unaware of it being  
distributed as fat-binaries and even less for Ruby 1.9 support.

Since you’re running Ruby from RubyInstaller, those are my  
assumptions, but I might be wrong.
