Rails stopped working on mac


#1

I had rails working on my ibook (using Tiger) a couple days ago…went
through a tutorial and such, and everything worked. But now if I try to
run the ‘ruby script/server’ command, I get the No such file to
load–ruby gems error
./script/…/config/boot.rb:18:in require': No such file to load -- rubygems (LoadError) from ./script/../config/boot.rb:18 from script/server:2:inrequire’
from script/server:2
I don’t know what I did to cause this…I tried reinstalling rubygems
and rails, but nothing worked. Any ideas? (Maybe a full uninstall
first?–how would I do this?)
Thanks


#2

On 14 May 2006, at 4:20 am, Kirk Colenbrander wrote:

I don’t know what I did to cause this…I tried reinstalling rubygems
and rails, but nothing worked. Any ideas? (Maybe a full uninstall
first?–how would I do this?)

Have you just installed the latest Apple security upgrade? I think
that upgrades the version of ruby that comes with the OS, which I
suppose might have broken someting if your original install had
included removing the (broken) ruby that came with 10.4.

I had a similar problem after switching from a manually installed
version of ruby to using the latest one from DarwinPorts[1]. The
solution was to install rubygems using DarwinPorts too, then
reinstall all the gems I needed (at least rails to start with). With
this setup, as long as /opt/local/bin/ is first in your PATH (set it
in ~/.profile), it should un everything from the ports install rather
than anywhere else. Doing it this way also means you can upgrade ruby
etc in future independently of the version that comes with the OS.

Kerry