Rails freeze, weird error


#1

Hello –

So, I have a bunch of apps on my dev box, all currently v1.0.0. I
thought I
could use the freezing techniques to test each app for 1.1.x
compatibility
individually, but that doesn’t seem to be working out…

First, I checked out from
http://dev.rubyonrails.org/svn/rails/tags/rel_1-1-2/ into vendor/rails

Then I ran “rake rails:update”.

Then I went into console, and tried to check the current version of
Rails:

$ rake rails:update
$ ruby script/console
Loading development environment.
/usr/lib/ruby/1.8/test/unit/assertions.rb:265: warning: already
initialized constant UncaughtThrow
./script/…/config/…/config/…/vendor/rails/activerecord/lib/…/…/activesupport/lib/active_support/dependencies.rb:100:in
`const_missing’:NameError: uninitialized constant
ActionController::TestProcess

Rails::VERSION::STRING
=> “1.0.0”

Loaded suite irb
Started

Finished in 0.0 seconds.

0 tests, 0 assertions, 0 failures, 0 errors
/usr/lib/ruby/1.8/irb.rb:76:in throw': uncaught throwIRB_EXIT’
(NameError)
from /usr/lib/ruby/1.8/irb.rb:76:in irb_exit' from /usr/lib/ruby/1.8/irb/context.rb:226:inexit’
from /usr/lib/ruby/1.8/irb/extend-command.rb:24:in `exit’
from /usr/lib/ruby/1.8/test/unit.rb:285
from /usr/bin/irb:13

I’m guessing, for now, that I can’t do what I wanted to do (Rails 1.1.x
from
vendor/rails externals) but I’m not sure why. And, does this mean that
I’ll
be unable to jump to Rails 1.1.x until my shared host goes at least
that
far? (In other words, this freezing business appears to only work going
backwards, not forwards.)


#2

Ah, well… A little extra Googling tells me the problem is actually
from
using the Engines plugin.

Removing the “Engines.start” line didn’t fix this, however; I had to
remove
engines from my plugins directory to make it go away.