RadRails install plugin problem

Hi,

I’m having a problem installing plugins in the latest version of
radrails running on windows XP.

I used the Plugin window in radrails to select file_column to install
file_column and everything worked ok.

Now i want to install remote_upload plugin which isnt in the plugins
list contained in radrails. So i select plugin from the generators tab
and type remote_upload and hit return. This instals the correct folder
in the vendors folder but all of the files contain just comments like
below.

Http:::::Sean.treadway.info::Svn::Plugins::RespondsToParent

Can anyone tell me how to install the plugin with all the files. The
link is below and i have tried putting the url in the plugin field to
install without success. I’m having the same problem for
responds_to_parent. Is their a specific way to install 3rd party
plugins?

http://svn.kylemaxwell.com/upload_reference_app/vendor/plugins/remote

John B. <[email protected]…> writes:

list contained in radrails. So i select plugin from the generators tab
plugins?

http://svn.kylemaxwell.com/upload_reference_app/vendor/plugins/remote

Hi John,

I was able to install the plugin using Radrails 0.7 command prompt.

Here is what you need to do

  1. Install Ruby Win32 SSPI with the gem available at
    http://rubyforge.org/projects/rubysspi/ by coping it on locally, and
    execute gem
    install rubysspi in the same folder
  2. Copy ruby\lib\ruby\gems\1.8\gems\rubysspi-0.0.2-i386-mswin32\spa.rb
    to
    ruby\lib\ruby\site_ruby\
  3. Edit ruby\bin\gem.bat to provide â??rspa for ruby command (line number
  1. Edit environment variables http_proxy, http_user, http_pass to
    http://ptproyx.persistent.co.in:8080 , your domain user and your domain
    password
  2. Start command prompt in RadRails and give following command
    ruby -rspa script/plugin install
    http://svn.kylemaxwell.com/upload_reference_app/vendor/plugins/remote_upload/

That’s it.

HTH,
Ashutosh

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs