Radrails help

I’m annoyed at having the always reset the server every time i edit
something in my app. I believe this could be from accidently being in
production mode?

How do i configure mongrel or any other server to be in development or
production mode?

unless someone has another idea as to why i keep on having to reset my
server to see updates in the browser.

thank you very much

Dominic

script/server starts a webrick/lighty in development mode.
mongrel_rails start -e development also does this.

You could have a RAILS_ENV environment variable set (to ‘production’)
which
might be the reason this is happening. Easy to test, just tail
log/development.log and log/production.log and see which scrolls by as
you
click on links in your app.

Also, some changes require a restart (config/environment.rb) etc.

(This is not Radrails specific)

Vish

Thank you for that common sense feeling tip.
Turns out i have been resetting because i’ve been having a new thead
server open.

Vishnu G. wrote:

script/server starts a webrick/lighty in development mode.
mongrel_rails start -e development also does this.

You could have a RAILS_ENV environment variable set (to ‘production’)
which
might be the reason this is happening. Easy to test, just tail
log/development.log and log/production.log and see which scrolls by as
you
click on links in your app.

Also, some changes require a restart (config/environment.rb) etc.

(This is not Radrails specific)

Vish

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs