Quickk fix for engine on dreamhost with 1.1.5

HI all

this is a quick fix to get you rails app running on dreamhost if engines
has
stopped since the 1.1.5 upgrade

comment out line 6 and 7 in
vendor\plugins\engines\lib\engines\engines.rb as
the require ‘rails_version’ will give you an error like

/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:18:in
`require__’:
no such file to load – rails_version (MissingSourceFile)

quick and dirty

e.g engines.rb

begin
#require ‘rails_version’ # Rails 1.0, 1.1.0
#rescue
require ‘rails/version’ # renamed as of Rails 1.1.1
end

cheers

dion

www.blogsaic.com

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs