Problems at running Rails at the first time


#1

Well, i got familiar with writing Ruby scripts the last days and thougt
to
write a web application with a framework. First steps was Rails.

I successfully installed Gems, Action Web Service and Rails, at least
the
installer said so… :smiley:

So I took a tutorial to write a small app, but I fail in the step
startig
Rails with the command “rails myappdir”. There are some warnings and
error
messages:

first:
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/vendor/builder/blankslate.rb:26:
warning: instance_methods: parameter will default to ‘true’ as of 1.8.1

then 25 times:
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/vendor/builder/blankslate.rb:21:
warning: instance_methods: parameter will default to ‘true’ as of 1.8.1

then:
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/option_merger.rb:3:
warning: instance_methods: parameter will default to ‘true’ as of 1.8.1

then again 5 times:
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/vendor/builder/blankslate.rb:21:
warning: instance_methods: parameter will default to ‘true’ as of 1.8.1

for variety:
/usr/lib/ruby/gems/1.8/gems/activerecord-1.14.2/lib/active_record/associations/association_proxy.rb:7:
warning: instance_methods: parameter will default to ‘true’ as of 1.8.1

again 5 times:
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/vendor/builder/blankslate.rb:21:
warning: instance_methods: parameter will default to ‘true’ as of 1.8.1

one time:
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_view/helpers/form_helper.rb:380:
warning: instance_methods: parameter will default to ‘true’ as of 1.8.1

and the last one:
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/vendor/builder/blankslate.rb:21:
warning: instance_methods: parameter will default to ‘true’ as of 1.8.1
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:123:in
const_missing': uninitialized constant Soap (NameError) from /usr/lib/ruby/gems/1.8/gems/actionwebservice-1.1.2/lib/action_web_service.rb:57 from /usr/lib/ruby/gems/1.8/gems/actionwebservice-1.1.2/lib/action_web_service.rb:55:inclass_eval’
from
/usr/lib/ruby/gems/1.8/gems/actionwebservice-1.1.2/lib/action_web_service.rb:55:in
class_eval' from /usr/lib/ruby/gems/1.8/gems/actionwebservice-1.1.2/lib/action_web_service.rb:55 from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire__’
from
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
require' from /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:inrequire’
from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:182:in activate' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:181:ineach’
from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:181:in activate' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:167:inactivate’
from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:166:in each' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:166:inactivate’
from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:37:in
require_gem_with_options' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:31:inrequire_gem’
from /usr/bin/rails:17

Am i doing something wrong? Did i miss to install some package? I
despair of
it…

greets,
BigMarser

View this message in context:
http://www.nabble.com/Problems+at+running+Rails+at+the+first+time-t1650649.html#a4471141
Sent from the RubyOnRails Users forum at Nabble.com.


#2

All inclusive 1-click Ruby/Rails development environments are free for
Windows and Mac OS X. Giveoneof these a whirl:

http://locomotive.raaum.org/ (Mac)

http://instantrails.rubyforge.org/wiki/wiki.pl?Instant_Rails (Windows)

Cheers.


#3

Oh, I thought, it was clear I want Rails running @ Linux… :slight_smile:

It is no option for me to try Windows or Mac, because they are not
given…
:smiley:

greets,
BigMarser

View this message in context:
http://www.nabble.com/Problems+at+running+Rails+at+the+first+time-t1650649.html#a4483560
Sent from the RubyOnRails Users forum at Nabble.com.